cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

Anonymous
Not applicable

Hello,

   

I am trying to run the USB chapter 9 tests with my FX3 device. For easily verfiy what happens I have flashed the SDK demo application cyfxbulksrcsink. With SDK version 1.2.3 I got an error during TD 9.27 as shown in the attached image. With SDK version 1.2.1 the complaince test suite runs without any error. What's wrong with the SDK 1.2.3 ?

0 Likes
5 Replies
RaN_283461
New Contributor

 Can you pls state in detail how you conducted this test ??

   

thanks

   

rags

0 Likes
Anonymous
Not applicable

* First download and install the official USB3 Command Verifier Tool from here http://www.usb.org/developers/ssusb/ssusbtools.

   

* Install FX3 SDK 1.2.1 and 1.2.3 described in this forum post https://secure.cypress.com/?app=forum&id=167&rID=74666.

   

* build FX3-SDK\1.2.1\firmware\basic_examples\cyfxbulksrcsink

   

* build FX3-SDK\1.2.3\firmware\basic_examples\cyfxbulksrcsink

   

(in both steps please look to the environment variable FX3_INSTALL_PATH, perhaps use a batch file to change it.)

   

* then start the tests with both builds. Then with the build from SDK 1.2.3 you will see my results from the first post.

   

 

   

regards Fritz

0 Likes
RaN_283461
New Contributor

 I tried with only one sdk 1.2.2 but the test report said it failed.

   

I tried with cyfxisosrcsink and cyfxuvcinmem , but got the same report , I have attached the report , please help.

   

Thanks

   

Rags

0 Likes
Anonymous
Not applicable

Hi,

   

Yes. SDK 1.2.3 is failing the compliance tests. But we fixed it internally and it is not uploaded on web still.

   

Please create tech support case to get the new SDK1.2.3 library which will pass compliance tests.

   

Thanks,

   

sai krishna.

0 Likes
Anonymous
Not applicable

How to run  USB2.0 Electrical Compliance Tests  using  this  Kit ?

   

Please help ...

   

 

   

Regards,

   

Ajit

0 Likes