cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

MoLa_3842091
New Contributor II

I have got a FX3S RAID-on-Chip USB Dongle and I'm using FT232H from adafruit to debug via UART but I don't know why debug messages doesn't appear on TeraTerm I also tried displaying using Putty but still didn't work. I did the following:

1- I installed necessary uart to usb bridge adafruit driver and did a loopback test and it worked.

2- I double checked the connections between the RAID-on-Chip USB Dongle and adafruit UART to usb converter(Tx, Rx and gnd) and they are ok.

3- I used the following setting to display debug messages using TerraTerm (baud rate 115200, 1 stop bit, Data 8 bit, no stop bit, no flow control)

But debug messages never displayed!

Any helpful reply would be appreciated

0 Likes
1 Solution
KandlaguntaR_36
Moderator
Moderator

As per the firmware, it looks fine.

I just checked the schematic of the RAID 1 Dongle. Eventhough the header shows UART_TX and UART_RX pins, but the these pins are not connected to FX3S UART pins.

You can see there are DPR1 and DPR2 below right corner of SPI flash on the USB Dongle. The default connections of DPR1 and DPR2 are between 1 and 2 (placed 0 ohm resistor - connectd to SPI flash MISO and MOSI) and the connection between 2 and 3 are open. The 3 pin of DPR1 and DPR2 are connected to HDR.

Therefore, please solder a wire to second pin of DPR 1 and DPR 2 to take out the UART TX and RX connections.

Connect these wires to adafruit board. Then you will see the UART prints.

View solution in original post

0 Likes
4 Replies
KandlaguntaR_36
Moderator
Moderator
In Raid 1 example project:
Please define DEBUG to enable the UART in IOMatrixConfig.
Note that the Debugprints (CyU3PDebugPrint) are commented out in the RAID1 project. Can you please uncomment them and check?
You may load any other firmware (USB Bulk Source Sink - C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\firmware\basic_examples\cyfxbulksrcsink) and check.
MoLa_3842091
New Contributor II

>> You may load any other firmware (USB Bulk Source Sink - C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\firmware\basic_examples\cyfxbulksrcsink) and check.

I loaded this firmware and I still have the same problem

>>Please define DEBUG to enable the UART in IOMatrixConfig.

Note that the Debugprints (CyU3PDebugPrint) are commented out in the RAID1 project. Can you please uncomment them and check?
DEBUG is defined and enabled in IOMatrixConfig and Debugprints are uncommented but still having the issue

/* Configure the IO matrix for the device.

     * S0 port is enabled in 8 bit mode.

     * S1 port is enabled in 4 bit mode.

     * UART is enabled on remaining pins of the S1 port.

     */

    io_cfg.isDQ32Bit        = CyFalse;

    io_cfg.s0Mode           = CY_U3P_SPORT_4BIT;

    io_cfg.s1Mode           = CY_U3P_SPORT_4BIT;

    io_cfg.gpioSimpleEn[0]  = 0;

    io_cfg.gpioSimpleEn[1]  = 0x02102800;                       /* IOs 43, 45, 52 and 57 are chosen as GPIO. */

    io_cfg.gpioComplexEn[0] = 0;

    io_cfg.gpioComplexEn[1] = 0;

    io_cfg.useUart          = CyTrue;

    io_cfg.useI2C           = CyFalse;

    io_cfg.useI2S           = CyFalse;

    io_cfg.useSpi           = CyFalse;

    io_cfg.lppMode          = CY_U3P_IO_MATRIX_LPP_UART_ONLY;

    status = CyU3PDeviceConfigureIOMatrix (&io_cfg);

Any idea what the problem is?

0 Likes
MoLa_3842091
New Contributor II

The problem is solved, thanks for your help!

I realised that i had some a hardware faulty!!

0 Likes
KandlaguntaR_36
Moderator
Moderator

As per the firmware, it looks fine.

I just checked the schematic of the RAID 1 Dongle. Eventhough the header shows UART_TX and UART_RX pins, but the these pins are not connected to FX3S UART pins.

You can see there are DPR1 and DPR2 below right corner of SPI flash on the USB Dongle. The default connections of DPR1 and DPR2 are between 1 and 2 (placed 0 ohm resistor - connectd to SPI flash MISO and MOSI) and the connection between 2 and 3 are open. The 3 pin of DPR1 and DPR2 are connected to HDR.

Therefore, please solder a wire to second pin of DPR 1 and DPR 2 to take out the UART TX and RX connections.

Connect these wires to adafruit board. Then you will see the UART prints.

View solution in original post

0 Likes