Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB EZ-PD™ Type-C Forum Discussions

drewfustini
Level 3
Level 3
10 replies posted 10 sign-ins 5 replies posted

I am trying to open a PSoC Creator project for the CCG3PA and it reports that the CCG3PA is an outdated device.   PSoC Creator 4.4 even lists the CCG3PA in the new features, so I am confused why the program is complaining that the CCG3PA is an outdated device.

Screenshot from 2021-02-08 23-08-22.png

Screenshot from 2021-02-08 23-08-45.png

Screenshot from 2021-02-08 23-09-55.png

0 Likes
1 Solution
PranavaYN
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 50 likes received

Hi,

PSoC Creator 4.4 supports CCG3PA. Can you go to Tools and select Find new devices.

Please share the following information:

  1. Do you have CCGx Power SDK installed?
  2. What version of Power SDK was the project you are trying to is created from?
  3. Were you not able to find CYPD3171-24LQXQ in Device selector?  You can use "series" filter set to CCG3PA to narrow the list.

 

Best regards,
Pranava

View solution in original post

2 Replies
PranavaYN
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 50 likes received

Hi,

PSoC Creator 4.4 supports CCG3PA. Can you go to Tools and select Find new devices.

Please share the following information:

  1. Do you have CCGx Power SDK installed?
  2. What version of Power SDK was the project you are trying to is created from?
  3. Were you not able to find CYPD3171-24LQXQ in Device selector?  You can use "series" filter set to CCG3PA to narrow the list.

 

Best regards,
Pranava
drewfustini
Level 3
Level 3
10 replies posted 10 sign-ins 5 replies posted

Thank you, installing the additional packages resolved the problem.

Screenshot from 2021-02-10 00-10-47.pngScreenshot from 2021-02-10 00-10-32.pngScreenshot from 2021-02-10 00-07-11.png

0 Likes