cancel
Showing results for 
Search instead for 
Did you mean: 

USB EZ-PD™ Type-C

rubycy4500
New Contributor

当接上cy4500时,EZ-PD analyzer utility 显示 not connected.请问如何debug这个问题

0 Likes
1 Solution
ShifangZ_26
Moderator
Moderator

1. 确认EZ-PD analyzer utility版本 和CY4500的硬件装载的固件是匹配的。目前EZ-PD analyzer utility有2个官方版本,一个版本是PD2.0 only,一个是PD3.0. 用户界面不一致。与此同时,固件版本也有两个,固件文件默认放置在EZ-PD analyzer utility的安装路径。

2. 确认CY4500的驱动安装正确并且正确的绑定到,一般情况下不需要手动绑定。例如在Windows 10的设备管理器下显示以下:

ShifangZ_26_0-1623371607417.png

 

3. 在CY4500 上电后,确认正面的呼吸灯被点亮。

 

Best Regards,

Lisa

View solution in original post

0 Likes
5 Replies
ShifangZ_26
Moderator
Moderator

1. 确认EZ-PD analyzer utility版本 和CY4500的硬件装载的固件是匹配的。目前EZ-PD analyzer utility有2个官方版本,一个版本是PD2.0 only,一个是PD3.0. 用户界面不一致。与此同时,固件版本也有两个,固件文件默认放置在EZ-PD analyzer utility的安装路径。

2. 确认CY4500的驱动安装正确并且正确的绑定到,一般情况下不需要手动绑定。例如在Windows 10的设备管理器下显示以下:

ShifangZ_26_0-1623371607417.png

 

3. 在CY4500 上电后,确认正面的呼吸灯被点亮。

 

Best Regards,

Lisa

View solution in original post

0 Likes
rubycy4500
New Contributor

三周前刚连过是能用。现在接上后正面的灯有在闪烁。

0 Likes
rubycy4500
New Contributor

确认EZ-PD analyzer utility版本 和CY4500的硬件装载的固件是匹配的---这怎么确认?

是不是支持PD3.0 utility的可以兼容PD2.0?

如何知道要装哪个版本的工具?

0 Likes
rubycy4500
New Contributor

最新状况:安装支持PD3.0的 utility就可以认到并正常log。现在读出firmware 版号 2.0.7.0.

请问现在可以刷回只支持PD2.0的firmware吗?同时搭配PD2.0的utility使用。如果可以,请问如何刷?

0 Likes
ShifangZ_26
Moderator
Moderator

1. 降回PD2.0完全没有必要,因为PD3.0兼容PD2.0.

2. 如果一定要降,可以重新烧写PD2.0的固件即可,固件在安装目录\Cypress\CY4500 EZ-PD Protocol Analyzer\1.0\Firmware

Best Regards,

Lisa

0 Likes