Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB EZ-PD™ Type-C Forum Discussions

labuc_3433551
Level 1
Level 1

I am trying to install the software referenced to in the CY4521 CCG2 Evaluation Kit.

I go to www.cypress.com, and see several possible options.

CY4521 EZ-PD CCG2 ISP (01/20/2017)

CY4521 EZ-PD CCG2 SETUP (01/20/2017)

CY4521 EZ-PD CCG2 SETUP ONLY (01/20/2017)

EZ-PD Configuration Utility (04/30/2019)

Every time I download CY4521 EZ-PD CCG2 SETUP and run it, I get:

"The installer is unable to proceed with the current operation. CyInstaller will start rollback operation.

Details

Error 1722. There is a problem with this Windows Installer Package.

A program run as part of the setup did not finish as expected.

Contact your support personnel or package vendor.

Action NewCustomAction1, location C:/Program Files (x86)\Cypress\EZ-PD Configuration Utility\CypressDriverInstaller.exe, command: /S"

I can successfully install CY4521 EZ-PD CCG2 SETUP ONLY, but it does not include the EZ-PD application.

When I install EZ-PD Configuration Utility, I get this message:

"The procedure entry point SetDifxLogCallbackW could not be located in the dynamic link library DIFXAPL.dll"

Then I get the same message I got when installing CY4521 EZ-PD CCG2 SETUP.

Advice?

0 Likes
6 Replies
YiZ_31
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi,

Have you tried the installation package for EZ-PD Configuration Utility only?

https://www.cypress.com/documentation/software-and-drivers/ez-pd-configuration-utility

Regards,
Eddie

labuc_3433551
Level 1
Level 1

I tried installing everything else, then installing the EZ-PD Configuration Utility stand-alone.

From my first mail:

When I install EZ-PD Configuration Utility, I get this message:

"The procedure entry point SetDifxLogCallbackW could not be located in the dynamic

link library DIFXAPL.dll"

Not reported in my first mail: The failing program is {Program Files (x86)\USB-Serial Driver\CyDriverInstaller_x64.exe

I used windows to uninstall everything published by Cypress.

Then I did another install from the 600+ MByte file I downloaded from the Cypress site.

Same failing result, same messages.

Unfortunately, Cypress software does a roll-back, deleting all the software it has installed, so it is hard to do anything with a partial install.

I can let the install fail, then pause before clocking "OK"

Now I see that the installer has made several files in

C:\Program Files (x86)\Cypress\EZ-PD Configuration Utility, notably CypressDriverInstaller.exe

C:\Program Files (x86)\Cypress\USB-Serial Driver, notably CyDriverInstaller_x64.exe, DIFxAPI.dll, and the directory DifxAPI

As background, this is Windows 7 Enterprise 64-bit (I thought it was 10...)

I run programs as Administrator

When I run CypressDriverInstaller.exe, I see "USB-Serial Driver Installer".

This invokes CyDriverInstaller_x64.exe

Then the installer deletes all the files it installed.

I need to get the Cypress USB-Serial Driver to install.

Any ideas?

0 Likes
labuc_3433551
Level 1
Level 1

I went to Cypress and downloaded CypressDriverInstaller_1.exe

https://www.cypress.com/documentation/software-and-drivers/usb-serial-software-development-kit

I run this, and it fails with this information:

"Windows Driver Installer for USB-Serial Devices

Installation Aborted

Setup was not completed successfully.

System Failed Copying files to Windows Temporary Directory. Unable to proceed..."

This is not informative.  It makes less of a message than the version I tried before.

I would not be surprised if it was having problems with the .dll too.

I see that this problem has been reported by someone (somewhere).

Cypress Semiconductor - USB - Known Problems and Solutions

Look for the word "Unable". No fix was supplied.

Need suggestions.

0 Likes

Same problem here.  Is there a solution?

0 Likes
labuc_3433551
Level 1
Level 1

Installed Cypress drivers on co-worker's computer. Worked fine.

I looked at his file C:\Windows\System32\difxapi.dll. It is identical to mine.

Downloaded the processor processor monitor Procmon from Microsoft.

Once I got rid of the endless chatter by Explorer and uagqecsvcand svchost, and others, I see that the Cypress driver install program is opening the correct .dll

I think it is likely that the .dll is not the problem.

The driver install program is interpreting something wrong, or clobbering something.

Its error message is misleading.

I manually installed the driver to the starter kit.

Now, I have to get the EZ-PD software installed on my program.

The Cypress install program runs almost to the end, has a problem installing teh serial line driver, then deletes all the files it just installed.

I need to be told how to avoid this unnecessary destructive pass.

Who knows how to make the install script skip its built-in roll-back?

0 Likes
labuc_3433551
Level 1
Level 1

My suspicions:

I tried to install the drivers for a Samsung Tablet on my Windows-7 laptop.

Drivers wouldn't install.

After much ineffective work, I found this site which shows how to manually install the CDC Serial Driver.

This site showed how to manually install a driver.

https://rootmydevice.com/install-adb-driver-windows-computer/

Following this procedure, I was able to install a driver which lets Android Studio connect to the tablet.

I plugged in a Cypress board instead of the tablet, and again I can't get the drivers to load.

I see a device called "CMCC ADB Device"/"Android ADB Interface".

This device is marked with a yellow exclamation mark, and reports "Device cannot start (Code 10), just like the Samsung ADB device,

I have been pursuing an install problem with the "CDC Abstract Control Model (ACM)", I believe from the Cypress driver install package.

I think my laptop is somehow rejecting new drivers.  The samsung procedure worked around the problem by installing the driver as a legacy device.

If I could separate the driver installation from the install of the rest of EZ-PD Configuration Utility, I could make progress.

Is this the correct site to ask for help?

Or is there some sort of official service request I can make?

0 Likes