Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB EZ-PD™ Type-C Forum Discussions

Geromino
Level 5
Level 5
50 replies posted 25 replies posted 10 replies posted

step 1:

Programming the CCG3PA Controller on the CY4532 EVK   ( following instruction in EZ-PD™ CCG3PA Evaluation Kit Guide.pdf)

i run Power Adapter (PA) Demo   with file CYPD3171-24LQXQ_cla_3_4_0_2274_0_0_0_pa.cyacd

set jumpers of main and power board  during update FW  as instructions  in (EZ-PD™ CCG3PA Evaluation Kit Guide.pdf)

after update FW unplug power and change  the  set jumpers  on main and power board  as in instructions (EZ-PD™ CCG3PA Evaluation Kit Guide.pdf)

power on the board  and plugin the usb-c sink ( mobile phone)  and check TP8 and TP11  and the test  was good Case 1: Voltage on both TP11 and TP8 ≥ 2.8 V

step 2:

in PSoC  creator  i open  example CYPD3175-24LQXQ_pa_direct_fb02_base  see attached photo   i followed  the  instruction in case another case  which i open see word attached file with the  corresponding

so i change the bootloader  and device configuration  build  noboot  and boot project compile   and  update  with usb type a  with (EZ-PD Configuration Utility)

with correct set jumpes  main and power board

power off the board reset the jumpers set working  mode  and run Power Adapter (PA) Demo   i plugin sink ( mobille)  to  type c  connector  but the charge not happen

since then happen following

step 1:

i tried update fw  to original  CYPD3171-24LQXQ_cla_3_4_0_2274_0_0_0_pa.cyacd  with EZ-PD Confiuration Utillity  (  with correct  set jumpers )  but the utility no recognize  the device (  the usb drivers in win7  are working properly )  see attached image  the error is Could not establish PD contract.

step 2 :

i tried  update fw to original   CYPD3171-24LQXQ_cla_3_4_0_2274_0_0_0_pa.cyacd  with miniProg3  it pass  but

after  set jumpers set by instruction  Set the jumpers on the CY4532 Main Board and Power Board as specified in Table 5-1.

happens following :

1) LED1  power off 

2) unable to update fw via usb type ( EZ-PD Confiuration Utillity)  CCG3PA Power Adapter with Direct Feedback Control  ()

3) if  plug in sink (  mobile phone ) to type c connector on main board  the phone does not charge

please  advice  i dont know  how continue with  non responding board

0 Likes
1 Solution

could we arrange  meeting  with share screen  it will easier to explain the issue or further investigation 

View solution in original post

0 Likes
3 Replies
PranavaYN
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 50 likes received

Hi,

Sorry for the miscommunication.

Can you please provide the voltages from TP4 on the power board, TP1 and TP4 on the main board so that we can further debug the issue.

Best regards,
Pranava
0 Likes

i connect  only dc 12v adapter

the  set jumpers  on power board is j6,j7,j9  are open  j14 close  then i connect ground TP1 and  v TP4  get 0 v

the  set jumpers  on main board  is j2,j3,j4 short 1,2 j6 short 2,3 j5 and j7 open  connect ground to TP16 and v to TP1  and TP4  get 0 v

on  power board j3  i messurure  the v is =12.25v

0 Likes

could we arrange  meeting  with share screen  it will easier to explain the issue or further investigation 

0 Likes