Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB EZ-PD™ Type-C Forum Discussions

RoLa_1225936
Level 1
Level 1
First like received First like given

In PSoC Creator 4.2 i created a new CCG2 Project. I loaded code example CYPD2122-24LQXI_mobile. I updated the components and tried to build the project and got the error message:ERROR: cannot find -lusbpd_gcc.

Any suggestions?

Best regards

Robert

0 Likes
1 Solution
YiZ_31
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi,

In the build setting, you should choose ARM MDK Generic for Toolchain.

pastedImage_1.png

Regards,

Eddie

View solution in original post

0 Likes
4 Replies
YiZ_31
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi,

In the build setting, you should choose ARM MDK Generic for Toolchain.

pastedImage_1.png

Regards,

Eddie

0 Likes

Hi Eddie,

I installed mdk528a and set toolchain to ARM MDK Generic, as you adviced. Now i get the following error:

Fatal error: L3900U: Unrecognized option '--vfemode=force'.

The command 'armcc.exe' failed with exit code '1'.

Best regards

Robert

0 Likes
YiZ_31
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi Robert,

I can successfully compile CYPD2122-24LQXI_mobile after updaing componet with mdk528a. If you still can not successfully compile the project, I suggest you use PSoC Creator 3.3 with ARM MDK Generic. The component will not need updating.

Regards,

Eddie

0 Likes

Hi, Eddie,

with the PSOC version 3.3 I had already tried it of course, the error is the same.

After I installed PSoC 4.2 and MDK528a on another computer everything works. Why I don't know.

Many thanks for your help

Robert

0 Likes