Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

TRAVEO™ T2G Forum Discussions

SaKu_4388591
Level 1
Level 1

Hi Team,

Presently I have software stack which will be updated by another software stack (called as Updater stack).

Both are differentiated and accessed with linker regions.

This updater shall erase and copy the new stack and resets.

Issue is after reset, the new stack copied should start because the startup code is available.

But the microcontroller is going to idle state.

Also unable to connect debugger after this copy.

In WinIdea, during connection showing as finished but actually not connected. Because of this unable to update actual code.

We have cross-checked the copy region and there is no access of wrong memory location/corruption.

Regards,

Sai Kumar Ponneri

0 Likes
1 Solution

Dear Sai Kumar Ponneri,

Unfortunately TVII topic can not be discussed in CDC (public space) now. We are very sorry for this.

So, could you please contact Cypress (An Infineon Technologies Company) sales representative?

It would be appreciated if you comprehend for this.

regards.

View solution in original post

0 Likes
3 Replies
TakashiM_61
Moderator
Moderator
Moderator
1000 replies posted 500 solutions authored 750 replies posted

Dear Sai Kumar Ponneri,

At first, could you please let us know which device you use?

regards.

0 Likes

Hi,

Controller is Cypress Traveo II CYT2B75CAS, Core CM0+ is being updated.

CM4 has the application stack and CM0+ has the bootloader.

Issue is ariased when CM0+ FBL is being updated by using application stack.

Regards,

Sai Kumar Ponneri

0 Likes

Dear Sai Kumar Ponneri,

Unfortunately TVII topic can not be discussed in CDC (public space) now. We are very sorry for this.

So, could you please contact Cypress (An Infineon Technologies Company) sales representative?

It would be appreciated if you comprehend for this.

regards.

0 Likes