Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

TRAVEO™ T2G Forum Discussions

sungbok
Level 1
Level 1
First reply posted First question asked Welcome!

I got  errors  when i flashed image by Miniprog4 in linux environment. 

Could you help to solve those errors ?

adapter speed: 2000 kHz
adapter srst delay: 25
adapter srst pulse_width: 25
** Auto-acquire enabled, use "set ENABLE_ACQUIRE 0" to disable
cortex_m reset_config sysresetreq
Info : CMSIS-DAP: SWD supported
Info : CMSIS-DAP: Atomic commands supported
Info : CMSIS-DAP: FW Version = 1.2.0
Info : CMSIS-DAP: Interface Initialised (SWD)
Info : SWCLK/TCK = 1 SWDIO/TMS = 1 TDI = 0 TDO = 0 nTRST = 0 nRESET = 1
Info : CMSIS-DAP: Interface ready
Info : KitProg3: FW version: 1.1.158
Info : VTarget = 3.377 V
Info : kitprog3: acquiring the device (mode: reset)...
Info : clock speed 2000 kHz
Info : SWD DPIDR 0x6ba02477
Info : traveo2_be_4m.cpu.cm0: hardware has 4 breakpoints, 2 watchpoints
***************************************
** Use overriden Main Flash size, kb: 4160
** Use overriden Work Flash size, kb: 128
** Silicon: 0xEA06, Family: 0x108, Rev.: 0x11 (A0)
** Detected Device: CYT2BL5CAE
** Flash Boot version: 3.1.0.556
** SFlash version: 367777
** Chip Protection: NORMAL
***************************************
Info : traveo2_be_4m.cpu.cm4: hardware has 6 breakpoints, 4 watchpoints
Info : starting gdb server for traveo2_be_4m.cpu.cm0 on 3333
Info : Listening on port 3333 for gdb connections
Info : starting gdb server for traveo2_be_4m.cpu.cm4 on 3334
Info : Listening on port 3334 for gdb connections
Info : SWD DPIDR 0x6ba02477
Info : kitprog3: acquiring the device (mode: reset)...
traveo2_be_4m.cpu.cm0 halted due to debug-request, current mode: Thread
xPSR: 0x61000000 pc: 0x000000f8 msp: 0x0807f800
Info : SWD DPIDR 0x6ba02477
Error: Failed to read memory at 0xe000edf4
Error: mem2array: Read @ 0xe000edf0, w=4, cnt=1, failed
Error executing event reset-deassert-post on target traveo2_be_4m.cpu.cm0:
/images/extra-bins/openocd//scripts/mem_helper.tcl:6: Error:

---- another error case---

 

 

 

0 Likes
4 Replies
Jin-HyungK_31
Employee
Employee
5 replies posted 5 sign-ins First like given

Dear Infineon Community Team,

I've uploaded a log file on behalf of Sungbok since file uploading from his site is blocked.

His technical question is related to miniprog4 programming using openocd(Auto Flash Util) and not directly related to T2G product itself. Thus, he wants to get some information how and when the "Error" messages appear.

rdgs,

Jin

0 Likes
AS_36
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 250 replies posted

Hi @sungbok @Jin-HyungK_31 

From the log I can notice that you are trying the flash erase sector command and it is failing.

Is this the only command you have tried so far? Have you tried any other commands that worked successfully? 

Can you try the flash info command and see if that work? That will also give you a result of the protection status of the flash sectors.

Regards.

0 Likes
sungbok
Level 1
Level 1
First reply posted First question asked Welcome!

Thank you for your  quick reply.

Those errors are reported from our OEM side. They are facing those kinds of errors when they are trying to erase/flash CM0+ and CM4 elf by Miniprog4. 

Those errors is sporadic and happened in all workers. So, I want to know the  meaning of those errors and which part I should check. 

Here is our whole flashing command and all command in automation script. 

If there is an error one of step, the script is stop. 

1. Erasing

sudo ./openocd -s ../scripts -f interface/kitprog3.cfg -c "transport select swd" -f target/traveo2_be_4m.cfg -c "init; reset init; flash erase_sector 0 0 last; shutdown"

2. Flashing

sudo ./openocd -s ../scripts -f interface/kitprog3.cfg -c "transport select swd" -f target/traveo2_be_4m.cfg -c "traveo2 sflash_restrictions 2; program cm0plus.elf 0x0 verify exit"

sudo ./openocd -s ../scripts -f interface/kitprog3.cfg -c "transport select swd" -f target/traveo2_be_4m.cfg -c "program CM4.elf 0x0 verify exit"

3. Set default magic word for dual bank

sudo ./openocd -s ../scripts -f interface/kitprog3.cfg -c "transport select swd" -f target/traveo2_be_4m.cfg -c "init; reset init; traveo2 wflash write_words 0x14018000 0xFFFFFFFF ; shutdown"

0 Likes
AS_36
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 250 replies posted

Hi @sungbok 

Can you try the flash info command and see if that work? That will give you a result of the protection status of the flash sectors. 

openocd -s ../scripts -f interface/kitprog3.cfg -c "transport select swd" -f target/traveo2_be_4m.cfg -c "init; reset init; flash info 0; shutdown"

Regards.

0 Likes