Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
iganda
Level 1
Level 1
First reply posted First question asked Welcome!

Hi,

I just got a Traveo-II starter Kit (CYTVII-B-E-1M-SK) and wanted to debug it using IAR Embedded Workbench IDE and the onboard debugger with the micro-USB cable.

When trying to debug the sample code that came with the TVII Sample Driver Library I always get a "Failed initializing emulator" error (see screenshot)

Do you have an idea what the issue migh be?

0 Likes
3 Replies
lock attach
Attachments are accessible only for community members.
Pranith
Moderator
Moderator
Moderator
100 sign-ins 50 sign-ins 25 replies posted

Hello @iganda ,

As a preliminary step you could check the device revision, you can cross reference the information printed on the silicon with the ordering code nomenclature table found in the datasheet here: https://www.cypress.com/file/511616/download

example: Traveo™ II CYT2B75CADES is a rev d device and CYT2B75CABES is a rev b device. 

You need to select the appropriate revision under the project workspace (shown in pic).

Kindly check your debugger settings under: Project>options> Debugger>Setup>driver: CMSIS DAP

Project>options> Debugger>CMSIS DAP>Interface > Probe config : Auto and Interface: SWD (shown in pic)

Regards,

@Pranith 

 

 

0 Likes
lock attach
Attachments are accessible only for community members.
iganda
Level 1
Level 1
First reply posted First question asked Welcome!

Hello @Pranith ,

Thanks! That did the trick for the M4. For the M0+ the debugger also starts but raises a HardFault exception on startup. Do you know what this could be? (see screenshot attached)

Best regards

0 Likes
lock attach
Attachments are accessible only for community members.
Pranith
Moderator
Moderator
Moderator
100 sign-ins 50 sign-ins 25 replies posted

Hello @iganda 

Usually this occurs when the appropriate device revision is not selected in your project window. The Hard fault traces back to InitRamECC() function, as reserved ram sections differ across revisions.  You can check the revision you have selected (Device_rev.png)
Could you let us know the device revision? Rev B/Rev C or Rev D?
Could you also let us know whether you are using the SDL or Starter kit software?

Regards,

@Pranith 

 

0 Likes