Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

TRAVEO™ T2G Forum Discussions

Incognito_Guy
Level 1
First reply posted First question asked Welcome!
Level 1

Hi

I am trying to do some AXI DMA operation to transfer the data between two locations.

The code that does the AXI DMA Configuration and triggers the operation resides in CM7_0.

After triggering the transfer, I am getting the DESTINATION BUS ERROR.

What does this mean? Also how do we debug this issues?

How is this AXI DMA different from normal DMA. Is it only the speed?

DMA Config:

  • Both Source\Destination address are in SRAM.
  • 1D Array transfer.

 

Thanks In Advance!

 

0 Likes
1 Solution
AS_36
Moderator
Moderator 500 replies posted 250 solutions authored 250 replies posted
Moderator
0 Likes
4 Replies
AS_36
Moderator
Moderator 500 replies posted 250 solutions authored 250 replies posted
Moderator

Hi @Incognito_Guy 

Could you please tell me more about your application and test setup?

Which Traveo T2G device are you using? Are you using our SDL? If yes, which version?

Regards.

0 Likes
Incognito_Guy
Level 1
First reply posted First question asked Welcome!
Level 1
Hi

Due to some reasons I can't reveal the device/SDL info.

Can you help me out with the causes of those error (i.e. destination bus
error)?
0 Likes
Incognito_Guy
Level 1
First reply posted First question asked Welcome!
Level 1

@AS_36 

The code is working after calling Scb_Disable_Dcache() API. I would like to know the significance of this API. 

Do you know how this works and why is it needed? 

Also please let me know if there is any documentation on this...

0 Likes
AS_36
Moderator
Moderator 500 replies posted 250 solutions authored 250 replies posted
Moderator

Hi @Incognito_Guy 

Please go through section 6.4.2 of the following application note https://www.infineon.com/dgdl/Infineon-AN224432_Multi_Core_Handling_Guide_in_Traveo_II-ApplicationNo...

Regards.

0 Likes