Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

roshc_3630626
Level 2
Level 2
First like received

Hi

I used the following method:

1. Press and hold the Recovery button (SW3).

2. Press and hold the Reset (SW2) button for 1 second.

3. Release SW2.

4. Release SW3.

But the board can't to be recovered, the user application previously running again after released SW3.

Which one can tell me what caused this?Thank!

Below is the application program:

void application_start(void)

{

    /* Initialize the transport configuration */

    wiced_transport_init( &transport_cfg );

    /* Initialize Transport Buffer Pool */

    transport_pool = wiced_transport_create_buffer_pool ( TRANS_UART_BUFFER_SIZE, TRANS_UART_BUFFER_COUNT );

#if ((defined WICED_BT_TRACE_ENABLE) || (defined HCI_TRACE_OVER_TRANSPORT))

    /* Set the Debug UART as WICED_ROUTE_DEBUG_NONE to get rid of prints */

    //  wiced_set_debug_uart( WICED_ROUTE_DEBUG_NONE );

    /* Set Debug UART as WICED_ROUTE_DEBUG_TO_PUART to see debug traces on Peripheral UART (PUART) */

    //  wiced_set_debug_uart( WICED_ROUTE_DEBUG_TO_PUART );

    /* Set the Debug UART as WICED_ROUTE_DEBUG_TO_WICED_UART to send debug strings over the WICED debug interface */

    wiced_set_debug_uart( WICED_ROUTE_DEBUG_TO_PUART );//WICED_ROUTE_DEBUG_TO_WICED_UART

    wiced_hal_puart_select_uart_pads( WICED_PUART_RXD, WICED_PUART_TXD, 0, 0);

#endif

    WICED_BT_TRACE("APP Start\n");

    /* Initialize Bluetooth Controller and Host Stack */

    wiced_bt_stack_init(hid_audio_management_callback, &wiced_bt_cfg_settings, wiced_bt_cfg_buf_pools);

//    wiced_rtos_create_thread();

    //ADD

    while(1)

    {

    }

}

1 Solution

The problem is solved, P5 of the sFlash and pin6  of the base board are opened.

Thanks for your support!

View solution in original post

12 Replies
BoonT_56
Employee
Employee
500 likes received 250 likes received 100 likes received

Can you confirm the part number of your EVK board?

0 Likes

Sorry, the EVK board part number is CYW920735Q60EVB-01.I wrote it wrongly.

0 Likes
roshc_3630626
Level 2
Level 2
First like received

On the CYW920735Q60EVB-01 board, the corresponding button labels are as follows :

1. Press and hold the Recovery button (SW1).

2. Press and hold the Reset (SW2) button for 1 second.

3. Release SW2.

4. Release SW1.

0 Likes

Can you check that on SW8, pin 3 is set to ON and pin 4 is set to OFF?

0 Likes
BoonT_56
Employee
Employee
500 likes received 250 likes received 100 likes received

You can press SW2 once (step 2) and let go (step 3). But do hold SW1 (step 4) for 1s before you let go. Let me know if this helps.

0 Likes

1:On SW8, pin 1 is set to ON、pin 2 is set to OFF、pin 3 is set to ON and pin 4 is set to OFF!

2:You can press SW2 once (step 2) and let go (step 3). But do hold SW1 (step 4) for 1s before you let go. Let me know if this helps.

I did the steps you said, but the problem was not solved.

0 Likes

1. After you do the recover procedure, how do you distinguish "the board doesn't recover and still run the previouse application"?

2. Why do you need to recover the device?

0 Likes

As far as the recovery procedure is concerned, it is correct. The most important step is to ensure the MOSI pin of the sFlash is shorted before a power cycle.

When you depress and hold SW1, can you use a multimeter to check whether pin6 is indeed grounded? Can you also do this for Pin5 (MOSI) of the sFlash?

If you report that the previous application is still running after releasing SW1/2, then it seemed to suggest that only a simple reset was done, and the sFlash was never isolated from 20735.

On the other hand, if the sFlash is not corrupted, you need not recover the board. You can continue to download your new app via the WICED SDK. Can you do it? Try the Hello_sensor sample for a start.

0 Likes

The problem I am facing now is that I can't re-download the program to the board.I try to ground the P5 of the sFlash directly.

0 Likes

1) Ground and Hold pin5

2) Exert Reset button

3) Release pin5 after 1s

If you are still unable to download, then it is highly probable that the EVB is broken somewhere.

0 Likes

The problem is solved, P5 of the sFlash and pin6  of the base board are opened.

Thanks for your support!