Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Studio Bluetooth Forum Discussions

Ezequiel
Level 1
First reply posted First question asked First like given
Level 1

Hello! I'm using the CYBT-343026-01 module and I've been having problems with the  packetization modes of CYSPP. (I'm sending messages via BT and recieving it on PUART) 

I was using the deafult anticipated mode but It was sending corrupted messages with a baud rate of 9600. So i decided to change to Immediate mode and it worked perfectly. My problem is that sometimes the module doesn't "remember" it's in immediate mode and works in anticipated mode aparently (It's sending corrupted messages). 

When this happens I send a  .CYSPPGK command to get the packetization mode, and it indicates its on immediate mode despite it's not working that way. 

UART Commands:

 13:48:55.836 -> .CYSPPGK
13:48:55.836 -> @R,0022,.CYSPPGK,0000,M=00,W=0A,L=14,E=0D 

How can I  make the module to always work correctly? Is there some parameter I'm missing to configure?

 

 

0 Likes
1 Solution
Charles_Lai
Moderator
Moderator 250 replies posted 100 solutions authored 100 replies posted
Moderator

Hi,

I checked the commands and they offer little to tune.

I think the problem could be caused by data overflow in the UART RX software buffer size.

You can try to:

  1. Enable flow control (CTS/RTS) on your UART link.
  2. Use a sniffer to capture the airlog, to verify if the module had transferred all the data correctly in sequence.

Best regards

View solution in original post

0 Likes
4 Replies
Charles_Lai
Moderator
Moderator 250 replies posted 100 solutions authored 100 replies posted
Moderator

Hi,

There could be some settings to configure this. Please wait while I'm reprising the issue and find the answer for you.

Best regards

Ezequiel
Level 1
First reply posted First question asked First like given
Level 1

Thanks! I am looking forward to your response.

0 Likes
Ezequiel
Level 1
First reply posted First question asked First like given
Level 1

Do you have any news on this matter?

0 Likes
Charles_Lai
Moderator
Moderator 250 replies posted 100 solutions authored 100 replies posted
Moderator

Hi,

I checked the commands and they offer little to tune.

I think the problem could be caused by data overflow in the UART RX software buffer size.

You can try to:

  1. Enable flow control (CTS/RTS) on your UART link.
  2. Use a sniffer to capture the airlog, to verify if the module had transferred all the data correctly in sequence.

Best regards

0 Likes