Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Studio Bluetooth Forum Discussions

AkJa_4647796
Level 4
Level 4
25 replies posted 10 replies posted 10 questions asked

Hi, I am using CYBT-343026-10 module with external MCU. communicating successfully using HCI command. But I have some doubt.

1. I am getting response but after sending the same reset command 4-5 times and sometimes I get 04 0E 04 01 03 0C 0C. Instead of getting 00 as my last byte I am getting 0C Which is command disallowed.

2. Here how i send commands.

RTS = 0;                   

//hardware reset

BT_RESET = 0;

delay(1000);

BT_RESET = 1;

//THEN I SEND RESET COMMAND

01 03 0C 00               

//CHANGE LOCAL NAME

01 13 0C 04 XYZT    

// SCAN ENABLE COMMAND

01 1A  0C 01 03

//WIRTE PAIRING MODE TO ENABLE THE PAIRING MODE

01 56 0C 01 01

I get correct response, but when i try to pair the BLE with my phone it doesnt connect and even sometimes it asked for 16-bit pin.

Do i need to send some other commands too? or i need to get out of command state of the module?

3. Can i used HCI uart to run further application?

Thank you.

0 Likes
1 Solution
Owen_Zhang123
Moderator
Moderator
Moderator
500 solutions authored 250 sign-ins 1000 replies posted

If you are going to use the module to transfer data with BLE or SPP, I suggest you to use the EZ-Serial FW. It is a UART-BLE bridge and easy to use. You just need to send some AT command through the PUART. Please take a look at the introduction for the EZ-Serial FW:

https://www.cypress.com/documentation/software-and-drivers/ez-serial-ez-ble-module-firmware-platform

https://www.cypress.com/file/455966/download

If you want to use the HCI command in your application, you need to run a bluetooth stack on your host MCU which may need more development.

View solution in original post

1 Reply
Owen_Zhang123
Moderator
Moderator
Moderator
500 solutions authored 250 sign-ins 1000 replies posted

If you are going to use the module to transfer data with BLE or SPP, I suggest you to use the EZ-Serial FW. It is a UART-BLE bridge and easy to use. You just need to send some AT command through the PUART. Please take a look at the introduction for the EZ-Serial FW:

https://www.cypress.com/documentation/software-and-drivers/ez-serial-ez-ble-module-firmware-platform

https://www.cypress.com/file/455966/download

If you want to use the HCI command in your application, you need to run a bluetooth stack on your host MCU which may need more development.