Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Studio Bluetooth

YoTa_1693656
Level 6
250 replies posted 250 sign-ins 100 replies posted
Level 6

Hello

[Description]

For RF test, I'm trying to use mbt tool during Bluetooth HCI mode.

In the case of mbt tool, No response from chip after sending mbt commands. On the other hand, in the case of wmbt tool, it works well.

[Environent]

- DUT:                  CYBT-343026-EVAL board.

- WICED-Studio version: 6.4

- Host Platform: Windows 10

[Log (Reset command)]

<mbt tool>

...\WICED-Studio-6.4\wiced_tools\mbt\Win32>mbt reset

MBT_TRANSPORT: COM6

DOWNLOAD_BAUDRATE: 115200 (default)

APPLICATION_BAUDRATE: 115200 (default)

Sending HCI Command:

0000 < 03 0C 00 >

⇒No response

<wmbt tool>

...\WICED-Studio-6.4\wiced_tools\wmbt\Release>wmbt.exe reset COM6

MBT_BAUD_RATE:  115200

TRANSPORT_MODE: 0 (HCI)

Opened COM6 at speed: 115200

Close Serial Bus

Opened COM6 at speed: 115200

Sending HCI Command:

0000 < 01 03 0C 00 >

Received HCI Event:

0000 < 04 0E 04 01 03 0C 00 >

Success

Close Serial Bus

⇒ Works fine

[Consideration]

The difference between mbt and wmbt is "01" existence or not.

mbt:  < 03 0C 00 >

wmbt: 01 03 0C 00

My understanding is the "01" is necessary for Bluetooth HCI mode.

[Question]

Does the mbt tool support Bluetooth HCI command? (not wiced HCI command)

If no, in the case of Bluetooth HCI mode, does Cypress recommend to use wmbt instead of mbt?

Thanks,

Yoshinori

0 Likes
1 Solution
YoTa_1693656
Level 6
250 replies posted 250 sign-ins 100 replies posted
Level 6

Hello

We use wmbt tool intead of mbt tool. So I close thei thread.

Thanks,

Yoshinori

View solution in original post

0 Likes
5 Replies
AnjanaM_61
Moderator
Moderator First comment on KBA 5 questions asked First question asked
Moderator

Hi Yoshinori,

The MBT tool uses HCI commands directly, whereas WMBT uses WICED HCI commands.

MBT tool should work. Not sure why its failing at your side. Can you please hard reset the board once and try once again ?

Regards,

Anjana

YoTa_1693656
Level 6
250 replies posted 250 sign-ins 100 replies posted
Level 6

Hello Anjana-san

Thank you for your prompt reply.  Unfortunately, it didn't resolve even if HW reset.

Here is additional info. In the case of bluetool, the reset command works well.

=======

47:36.831  com6   c>  Reset

                 HCI Command

           com6@115200

    [03 0C 00]

    opcode = 0xC03 (3075, "Reset")

47:36.843  com6   <c  Reset

                 HCI Command Complete Event

           com6@115200

    [0E 04]: 01 03 0C 00

    event = 0xE (14, "Command Complete")

    Num_HCI_Command_Packets = 0x1 (1)

    Command_Opcode = 0xC03 (3075, "Reset")

    Status = 0x0 (0, "Success")

=======

Thus, only mbt tool does not work fine under my environment. (wmbt and bluetool work fine.)

Just to be sure, I will check UART CTS level during the mbt tool.

Thanks,

Yoshinori

0 Likes
YoTa_1693656
Level 6
250 replies posted 250 sign-ins 100 replies posted
Level 6

Hello Anjana-san

I found out the root cause.

In the case of mbt tool, UART_CTS was H level during sending command from host under my environment.

Thus the chip did not send any data to the host. This means NO response from the chip.

mbt_default.jpg

I tried to set UART_CTS L level forcibly by pull-down.  Then the mbt tool became to work well.

====

...\WICED-Studio-6.4\wiced_tools\mbt\Win32>mbt reset

MBT_TRANSPORT: COM6

DOWNLOAD_BAUDRATE: 115200 (default)

APPLICATION_BAUDRATE: 115200 (default)

Sending HCI Command:

0000 < 03 0C 00 >

Received HCI Event:

0000 < 0E 04 01 03 0C 00 >

Success

====

mbt_pd.jpg

[Question]

Do you know the way to change UART_CTS polarity configuration of mbt tool?

Thanks,

Yoshinori

0 Likes
YoTa_1693656
Level 6
250 replies posted 250 sign-ins 100 replies posted
Level 6

Hello

We use wmbt tool intead of mbt tool. So I close thei thread.

Thanks,

Yoshinori

0 Likes
AnjanaM_61
Moderator
Moderator First comment on KBA 5 questions asked First question asked
Moderator

Hi Yoshinori San,

I was able to reproduce the issue with mbt tool.

Yes , please proceed with wmbt tool for now.

Regards,

Anjana

0 Likes