Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Level 3
Level 3
10 likes given 5 likes given First like received

I'm developing an application with CYBT-343026-EVAL. Since two days it's impossible to program the module and the WICED Studio print in console the following message:

Downloading application...

********* Download Failure *************


| Follow below suggestions and retry. |

|   1. Verify USB-UART driver is correctly installed |

|   2. Verify SW4 switches are in ON position (CTS, RTS, RXD, TXD) |

|   3. Power cycle CYBT-343026-EVAL and retry. |

| |

| If this problem persists, the serial flash on the board may be corrupted. |

| Follow below steps to reset CYBT-343026-EVAL board to factory default state.                |

| Note: This will erase any user applicaiton in the memory and reset the board to dafulat state |

|   1. Press and hold RECOVER button (SW2) |

|   2. Press and hold RESET button (SW1) for 1 second |

|   3. Release SW1 |

|   4. Release SW2 |

|   5. Re-program the board |


Download failed. This WICED platform of the SDK only supports download to 20706A2 device.

10:57:27 Build Finished (took 1m:27s.577ms)

I have followed all the seggestions and all the indeications in the guides and in the forum posts but nothing change. tried also to change J8 but without effect.

Only one time I was able to program it but then never again.

I have noticed that the RTS and CTS signal (by J1 connector) are alwais low for all the comunication until it fails. Is it right?

The drivers seem installed correctly, I can see two common "USB Serial Port" but I'm not sure they are correct because, if I'm not mistaken, it should be WICED HCI UART. I have tried to install the driver inside WICED Studio path but windows do not install it correctly. My OS is Windows 10.

Where could be the problem?

1 Solution


Cypress support replied to my case:

The abnormal kit can't be revised. Replace the kit or re-soldering the CYBT-323026 module.

View solution in original post

13 Replies
500 likes received 250 likes received 100 likes received

Just thinking out loud but did you use the right platform file?

Platform Files for CYBT-343026-EVAL – KBA221025


Thanks for your reply.

Yes, I'm using the same platform file that you suggest me.

Not applicable

Can you check the logto.log file that is generated inside the build folder. That should give us an idea about where it went wrong.

Regarding the COM ports, don't worry if you don't see HCI UART. The CYBT-343026_EVAL uses Cypress USB-Serial chip which has different drivers from the FTDI ones that you would've seen on the CYW20706WCDEVAL.

I have contacted a local support and we have analized the problem and the log. It seems that the problem is with the board hardware and it would seem not to be the first case.

I have already started the procedure for replacing it.


For CYBT-343026-EVAL downloading, please use the WICED Studio 6.1 or newer version.

If downloading failed, please follow the steps:

1. Make sure to use the CYBT-343026's platform: Platform Files for CYBT-343026-EVAL – KBA221025 

2. Try to do the recover steps(

1. Press and hold RECOVER button (SW2) |

|   2. Press and hold RESET button (SW1) for 1 second |

|   3. Release SW1 |

|   4. Release SW2 |

) and reprogramming.

3. If the kit's downloading slowly and slowly and finally failed with flash verification( logto.log file records the downloading failed reason), create the technical case or contact local distributor for such issue.

The behavior was the one described by you in point 3. The points 1 and 2 was verified but nothing changed.

I have just opened a technical case and I have provide to replace the board with a new one.

Its' a strange behavior, do you know what could be the problem? Is the problem due to flash damage?



Probably due to the flash damage, which version of WICED Studio do you used before?




Now I'm using WICED Studio 6.1 but last week I have tried to uninstall and reinstall it; I started to use wiced studio two month ago and I think the previous version wasn't very different from current one.

If the problem is the flash could be dangerous to use this module for a industrial production. Have you some suggestions for equivalent cypress modules? I need audio streaming and BLE (for data transfer).

However Cypress support have replied to my case:

Hi Luca,

I suspect this issue could be because of the driver used for the serial port.

I will check with the apps and tomorrow I will provide you an updated version of driver which is yet be released.




The industrial production will not damage the module, so the CYBT343026 is still the suggestion. The sflash damage due to the multi-downloading while your are develop the project. The WICED 6.1 should have fixed the multi downloading damage the sflash issue.

Could you please share the case number to me?

I meant that if flash stop to work it's a problem if I use this module in the product.

The problem is multi-downloading? But I have downloaded at most 100 times the firmware, no more. Is it the flash limit?

My case number is 00421887


Yes, I know your meaning, no worries and the multi-downloading issue will damage the sflash issue had fixed in WICED Studio 6.1.

Let's discuss your issue(I need the logto.log file to find out the root case) in case system.

lock attach
Attachments are accessible only for community members.

In attached you can find the logto.log file.



Cypress support replied to my case:

The abnormal kit can't be revised. Replace the kit or re-soldering the CYBT-323026 module.