Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Studio Bluetooth Forum Discussions

NiA_4003596
Level 3
Level 3
First like received Welcome!

Hi,

Could anyone please suggest how to resolve the status response is unreachable to few server nodes. Let me describe the system configuration to elaborate the problem being faced with CYW20706 devices. I have taken 5 lightness server nodes, a lightness client and a mobile application to provision.

I am sending the following messages from client

1. Status request (every 30 seconds) by passing network address 'C000', i used to get status of all server nodes

2. Every 10 sec, Send set value message first and then immediately status request by passing individual address , i used to get status of corresponding server node

The status messages of all server nodes being received to client for few minutes then one or two server nodes goes unreachable for status request but unfortunately it executes set value message. Yes it works set message to status unreachable nodes if i send 100% brightness or even tried different values between 0-100%. Please note that all devices kept within 1 meter distance.

Please advice to improve system performance as this is for cloud based smart lighting application and need response from all server nodes.

Best regards,

Niresh

0 Likes
1 Solution
DheerajPK_41
Moderator
Moderator
Moderator
750 replies posted 500 likes received 500 replies posted

Hi,

Could you please enable the Model and Core traces in the applications and share the logs with us?

-> Please try to delete all the temp files generated by the provisioner and try it again freshly.

-> May I know from which SDK you have taken lightness server/client applications? Also which is your provisioner?

-> Is there any node configured to work as Low Power Node?

-> Are you trying to remove any nodes from the network?

This can lead to initiate the key refresh procedure, and if the key refresh procedure stuck at phase 2 can actually cause the similar issue which you have described. At phase 2, the nodes will transmit using the new keys but can receive using the old keys and the new keys.

Thanks,

-Dheeraj

View solution in original post

0 Likes
1 Reply
DheerajPK_41
Moderator
Moderator
Moderator
750 replies posted 500 likes received 500 replies posted

Hi,

Could you please enable the Model and Core traces in the applications and share the logs with us?

-> Please try to delete all the temp files generated by the provisioner and try it again freshly.

-> May I know from which SDK you have taken lightness server/client applications? Also which is your provisioner?

-> Is there any node configured to work as Low Power Node?

-> Are you trying to remove any nodes from the network?

This can lead to initiate the key refresh procedure, and if the key refresh procedure stuck at phase 2 can actually cause the similar issue which you have described. At phase 2, the nodes will transmit using the new keys but can receive using the old keys and the new keys.

Thanks,

-Dheeraj

0 Likes