Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Studio Bluetooth Forum Discussions

RaSa_4767806
Level 3
Level 3
10 replies posted 10 questions asked 5 replies posted

Hello,

I have combined Battery Service and Generic OnOff Service  models and flashed to two CYBT 423028 Dev boards.

Then one CYBT 423028 board is flashed with combined Battery client and Generic OnOff Client Model.

All three boards are provisioned through MeshClient Windows App. All Server and client boards are powered through Laptop's USB port. With this configuration all boards are working as expected, I could able to set/Reset LED on Server boards, and could able get the battery status from server to client.

If I provide power to one of the server board through USB mobile Charger I am not getting response from Dev board which is connected to USB Mobile charger, but the board which is connected to Laptop's USB port responds as expected.

Instead of connecting to Charger if board is connected to different PC or Laptops USB port then it functions as expected.

If the same board which was powered through USB charger, again powered by Laptops USB port then it functions as expected again.

Some times, if I connect board to Laptops USB port and connect it to USB mobile charger it function as expected.

But If I flash Light Dimmable code to Dev boards and power it through Mobile USB charger then it functions as expected.

Is there any hardware limitation on powering CYBT423028 from Mobile USB charger or other external power supply (5V_Bus) or is it a firmware issue ?

0 Likes
1 Solution

Hi,

I am extremely sorry about not mentioning that the issue got resolved.

It not related to Power source.

In code by mistake I kept PURAT enabled with Rx interrupt, and Tx, Rx pins ware left open, when i disabled the PUART, boards are functioning as expected. When i connected to Mobile charger the Tx, Rx pins ware left floating and causing the issue.

Thanks

View solution in original post

2 Replies
DheerajPK_41
Moderator
Moderator
Moderator
750 replies posted 500 likes received 500 replies posted

Hi,

There is no such limitation if the input power is in the permissible limit.

  • Are you using "CYBT-423028-EVAL" or CYBT-423028 based custom board?
  • Also, May I know what is the rating of the mobile charge you are using?
  • May I know which SDK are you using?

"Some times, if I connect board to Laptops USB port and connect it to USB mobile charger it function as expected."  -> Could you please explain the steps/process once again?

I hope you are using the appropriate patches as mentioned in Platform and New Patch Files For 20719B1 in WICED 6.4.0.61 - KBA228518 . If not please use it.

Thanks,

-Dheeraj

0 Likes

Hi,

I am extremely sorry about not mentioning that the issue got resolved.

It not related to Power source.

In code by mistake I kept PURAT enabled with Rx interrupt, and Tx, Rx pins ware left open, when i disabled the PUART, boards are functioning as expected. When i connected to Mobile charger the Tx, Rx pins ware left floating and causing the issue.

Thanks