Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
chho_4472146
Level 1
Level 1

Hello,

I want to use the CYBT-333032-02 with linux via HCI UART inteface.Do i need to install a driver or linux will autodetect the module ?
I found that the CySmart is only supported on windows pc and also the ModusToolbox™ Software Environment is available on windows and linux but doesn't support the CYBT-333032-02.

Many thanks for help

0 Likes
1 Solution
AnjanaM_61
Moderator
Moderator
Moderator
10 questions asked 5 comments on KBA First comment on KBA

Hello,

Q) I want to use the CYBT-333032-02 with linux via HCI UART inteface.Do i need to install a driver or linux will autodetect the module ?

A : CYBT-333032-02 is supported in WICED studio 6.4 SDK which is available in linux as well. Install SDK from : WICED Studio Wi-Fi/Combo Docs & Downloads

Q) CySmart

CySmart is available only in Windows PC. However if you are looking for a BLE client app for testing, CySmart mobile app is available for Android and iOS : https://www.cypress.com/documentation/software-and-drivers/cysmart-mobile-app 

Thanks,

Anjana

View solution in original post

0 Likes
1 Reply
AnjanaM_61
Moderator
Moderator
Moderator
10 questions asked 5 comments on KBA First comment on KBA

Hello,

Q) I want to use the CYBT-333032-02 with linux via HCI UART inteface.Do i need to install a driver or linux will autodetect the module ?

A : CYBT-333032-02 is supported in WICED studio 6.4 SDK which is available in linux as well. Install SDK from : WICED Studio Wi-Fi/Combo Docs & Downloads

Q) CySmart

CySmart is available only in Windows PC. However if you are looking for a BLE client app for testing, CySmart mobile app is available for Android and iOS : https://www.cypress.com/documentation/software-and-drivers/cysmart-mobile-app 

Thanks,

Anjana

0 Likes