Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Smart Bluetooth Forum Discussions

PrSh_3615356
Level 1
Level 1

Hi,

I am trying to use CYBLE_0130025 Eval board to learn EZ Serial Binary command mode.

I have kept Switch 1-4 in OFF position and Switch 5-6 ON Position.

I am using Realterm to see if after sending Binary Command, I can see response. But there is nothing happening.

Eventually I want to use Arduino to send commands using UART to BLE for various settings.

Can somebody please let me know where I am wrong? Or from where to get relevant information. I have studied EZ Serial user guide.

Regards

0 Likes
1 Solution

You need to download the EZ-Serial firmware, then you can use the command in the user guide.

Please find the firmware for 013025 in the following link: http://www.cypress.com/documentation/software-and-drivers/ez-serial-ez-ble-module-firmware-platform .The V1.1.2 is for wiced module.

Please refer to this KBA about how to download the EZ-Serial firmware to the module.

Downloading into the CYBLE-013025-00 module – KBA222505

View solution in original post

0 Likes
4 Replies
Owen_Zhang123
Moderator
Moderator
Moderator
500 solutions authored 250 sign-ins 1000 replies posted

Could you see the response when you press the reset button(SW2)? Please check the settings of the Realterm, the default settings should be as 115200 / no parity / 8 bits / 1 stop bit / flow control off.

0 Likes

Hi,

Thanks for reply. I checked everything is okay.

I have used the evaluation board with Wiced Smart IDE and tested some programs there. The last one which is running on Evaluation board is find_me program. I hope this is not creating the problem.

Following is the setting on Realterm

pastedImage_2.png

When I press SW2 nothing is displayed on realterm (when Switch 5 is ON and Swithc 6 is ON).

This is screen when I send command: See TXD..

pastedImage_3.png

I also tried Python Script for text to binary conversion. I don't see response there also.

I see following:

pastedImage_0.png

For testing, I tried all combinations of Switches but no success.

I thing something is wrong with UART. I have also tried to send command from Arduino UART to P0 and P2 (UART RX,TX) on board.

There also I see Echo of the command send, no other response.

Please suggest what I am doing wrong.

0 Likes

You need to download the EZ-Serial firmware, then you can use the command in the user guide.

Please find the firmware for 013025 in the following link: http://www.cypress.com/documentation/software-and-drivers/ez-serial-ez-ble-module-firmware-platform .The V1.1.2 is for wiced module.

Please refer to this KBA about how to download the EZ-Serial firmware to the module.

Downloading into the CYBLE-013025-00 module – KBA222505

0 Likes

Hi zhxh

Thanks. It solved the problem. I was thinking to upload the binary using Wiced Software. But it was supposed to be done using command line.

I put the image into build folder, renamed the folder and file. Then I executed following command

Tools\ChipLoad\Win32\ChipLoad.exe -BLUETOOLMODE -PORT COM29 -BAUDRATE 115200 -MINIDRIVER Platforms/CYBLE_013025_EVAL/uart_DISABLE_EEPROM_WP_PIN1.hex -BTP Platforms/CYBLE_013025_EVAL/20737_SFLASH.btp -CONFIG build/ezserial_013025-CYBLE_013025_EVAL-rom-ram-Wiced-release/ezserial_013025-CYBLE_013025_EVAL-rom-ram-Wiced-release.hex -CHECKCRC -NOVERIFY -DLMINIDRIVERCHUNKSIZE 251

Now I get proper response.

Thanks again,

0 Likes