Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Smart Bluetooth Forum Discussions

MichaelF_56
Moderator
Moderator
Moderator
250 sign-ins 25 comments on blog 10 comments on blog

The WICED Sense App for Android is now available: WICED Sense - Android Apps on Google Play

The WICED Sense for Android is the client application for Broadcom's WICED Sense development TAG.  The WICED Sense TAG is made up of the BCM20737S Bluetooth Low Energy SoC and five ST Microelectronics sensors: gyroscope, accelerometer, eCompass, pressure, and humidity/temperature. The BCM20737S connects directly to the sensors without the need for an external microprocessor. WICED Sense for Android displays the real-time data from the sensors on the TAG.

WICED-Sense.png

0 Likes
23 Replies
Anonymous
Not applicable

Application availability seems to be restricted in some countries. Could you please let us know in which country you made the app available for download.

Anonymous
Not applicable

I have the same problem, I think,  it says I have no compatible devices, yet other Broadcom Apps I can install with no problem.

I'm in Australia.

Colin

0 Likes
Anonymous
Not applicable

I can now download the app. Problem solved. Thanks

0 Likes
Anonymous
Not applicable

Great!

JT

0 Likes
Anonymous
Not applicable

I am looking for the source code for Wiced Sense App, Smart explorer and SMART find me. Is that available somewhere?

Thanks!

WW

0 Likes

The source for those two applications will not be provided.

Only WICED Sense.

0 Likes
Anonymous
Not applicable

hi mwf_mmfae,

is there source to the WICED Sense Android app available for download somewhere?  (I have the iOS one, looking for the android one).

thanks so much.

0 Likes
Anonymous
Not applicable

Hello Mike,

We will be releasing the Android source code shortly.

JT

Anonymous
Not applicable

Hallo,

My android handy  is displaying  --Your device is not compatible with this version--

Android version is 4.1.2 it is a AT-AS53N phone

The wiced sense app  is 1 okt 2014

My ipad makes no connection with blue tooth and the orange wiced sense device ,it is totally invisible

So The app wiced sense is useless

I live  in Holland

Anny advice?

Thanks in advance

Gr Hans

0 Likes
Anonymous
Not applicable

Hello Gr Hans

The Android App is only compatible with Android version 4.4.

The iOS App is only compatible with iOS 4S phone and above that contain the Bluetooth Low Energy Radio.

We do not currently support the WICED Sense App on the iPad.

Thank you

JT

0 Likes
Anonymous
Not applicable

Hi JT

Thanks for the quick answer.

I am disappointed about the answer. The BT radio from my PC can see the device , so I can play with the wiced sense.But no app for the PC...!

I bought the device for mounting on my satelite disk from my camper.

On my  android device I should manually turn my disc into the right direction with the right elevation.(Astra19 or Astra 23). By Using the wiced sense there is no need for any wiring to the disk on the roof from the camper

I can look for a cheap android 4 device (phone) to experiment further.

Have a nice day!

Gr Hans

0 Likes
Anonymous
Not applicable

If it is of any help, there are versions of Android for the PC.

I use Android (4.4) installed on a USB stick and boot my PC from that. I assume Android would work in a VM as well.

The only problem I have with this is that Android keeps losing the Wiced, and then although it is showing as connected in the WiFi manager, it won't talk again until the whole system is rebooted. That may also be down to the BT dongle I'm using on the PC.

0 Likes
Anonymous
Not applicable

I just updated the Android app, and found there is some description in what's new. There is a suggestion to update the firmware of WICED Sense to 1.3. Where can we get the firmware to update?

WICED Sense - Android Apps on Google Play

What's New

Added OTA firmware update support.

Fixed refresh issues with UI.

Fixed Bluetooth LE connection issues.

Please update your WICED Sense Tag to firmware version 1.3

0 Likes

WICED Sense 2.1 firmware is available here: WICED Sense SDK 2.1 Firmware.zip

Anonymous
Not applicable

This app is not working with android 4.2.1. If this app has to be sucessfull it should support 4.0 onwards

0 Likes

I believe there are a couple of other threads here that state it requires Android 4.3 or later.

0 Likes
Anonymous
Not applicable

Shiv,

The WICED Sense tag works with Bluetooth Low Energy.

The Android O/S did not include Bluetooth Low Energy into the operating system/framework until Android 4.3.

Android 4.0 and 4.2 did not include Bluetooth Low Energy APIs into the framework. If your refer to the following link,

BluetoothGatt | Android Developers

you will see that Bluetooth Gatt APIs appeared only with Android API 18 (which is 4.3 JellyBean).

Android 4.3 APIs | Android Developers

There is no API provided by Google before JellyBean to support Bluetooth Low Energy, so we cannot be backward compatible to functionality that did not exist prior to 4.3.

Anonymous
Not applicable

Ok my point is to convey that it should be leftest Yet backward compatible. I'm not an android developer. but going forward there is need to make sure it is install-able and working for majority of market device. if you go with moore law. at least it should compatible with 18 month before launched device version. as if you so most successful app like whatsup they are compatible with 4.3 onward as well as before it.

0 Likes
Anonymous
Not applicable

Hello Shiv

BLE was introduced in JB MR 4.3 and was flakey on lots of phones when it was introduced on proprietary BLE Stacks

The BLE stack was improved in 4.4 and is still it completely bug-free today

Good luck on the Hackathon!

JT

Anonymous
Not applicable

Hi Shiv,

It's a Google/Android limitation.  It did not support BLE until version 4.3 or after.

Cheers, Gil.

0 Likes

Android 4.4 (KitKat) offered hit or miss BLE support

Android 5.0 (Lollipop) is by far the most consistent.

I can't find the apps on the googe store. Do you have an apk for an OTAFU?

I find an apk for SOTAFU but I have a BCM20736S and it can't support rsa

0 Likes