cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Bluetooth

Anonymous
Not applicable

In SDK2.1.1, I tested hello-sensor.

I substituted GPIO_PIN_BUTTON, and GPIO_SETTINGS_BUTTOn in hello_sensor_gpio_cfg with -1 and 0.

and I inserted bleprofile_PrepareHidoff() at the end of hello_sensor_create();

When I push SW1, I expected it did not wake up, but it did.

I inserted gpio_configure(0/16, 0%16, GPIO_INTERRUPT_DISABLE,0);

but the result was same.

What should I do to  disable GPIO_P0 as interrupt source?

0 Likes
1 Solution
BoonT_56
Employee

can you access include/drivers/gpiodriver.h? gpio_p0 to p15 is called Port0. There are options to set them to high impedance which also mean disabled.

View solution in original post

3 Replies
BoonT_56
Employee

Not sure if this link is useful to you...

GPIO in high impedance mode

0 Likes
Anonymous
Not applicable

boonst,

I appreciate for your answer, but it did not work.

The result is same.

0 Likes
BoonT_56
Employee

can you access include/drivers/gpiodriver.h? gpio_p0 to p15 is called Port0. There are options to set them to high impedance which also mean disabled.

View solution in original post