Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Smart Bluetooth Forum Discussions

Nera_4289606
Level 1
Level 1
First like given

I am using CYW920819EVB-02 board.I am try to making simple BLE-based application for the CYW20819 device using the ModusToolbox IDE based on Find Me Profile (FMP) .I am following the user guide provided by the Cypress.The code is uploaded successfully into the board,but the pairing is rejected by the board when i supposed to connect the board with the cypress application.Anyone can help me to solve these issue?

kk.jpg

0 Likes
1 Solution
Owen_Zhang123
Moderator
Moderator
Moderator
500 solutions authored 250 sign-ins 1000 replies posted

Are you using the FindMe demo from the git and the CYSmart app on your phone?

Per my test, the CYSmart can connect and communicate with the FindMe demo successfully. But it actually can't pair with it.

I checked the code, some events for pairing in the app_bt_management_callback() are missing. You can refer to the hello sensor demo and try to add the related event in hello_sensor_management_cback() to the FindMe demo.

View solution in original post

2 Replies
Owen_Zhang123
Moderator
Moderator
Moderator
500 solutions authored 250 sign-ins 1000 replies posted

Are you using the FindMe demo from the git and the CYSmart app on your phone?

Per my test, the CYSmart can connect and communicate with the FindMe demo successfully. But it actually can't pair with it.

I checked the code, some events for pairing in the app_bt_management_callback() are missing. You can refer to the hello sensor demo and try to add the related event in hello_sensor_management_cback() to the FindMe demo.

Thank you, it is working..

0 Likes