Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Radar sensor Forum Discussions

shibiana
Level 2
Level 2
5 questions asked 25 sign-ins 10 sign-ins

Hi,

I notice that a company called Blumio develops a kind of wearable blood pressure measuring device with BGT60TR13C. The measuring distance is about 1 cm to human's wrist. I wonder how I can configure BGT60TR13C to work in a proximal distance (maybe below 5 cm). I cannot manage to configure the device to work in such a short distance.

0 Likes
1 Solution
Siddharth
Moderator
Moderator
Moderator
10 solutions authored 10 likes given 25 replies posted

Hey @shibiana 

The error states that the frequency settings are out of the range, please check your Start and end frequency to be in the range of 58- 63.5 GHz. If it still doesn't work try with a fresh code by only changing the max range (chances are you might have changed some other configurations).

Thankyou, Siddharth

View solution in original post

0 Likes
4 Replies
Siddharth
Moderator
Moderator
Moderator
10 solutions authored 10 likes given 25 replies posted

Hello,

The minimum range you can configure in the Fusion GUI is 10 cm. But, you can set range as small as 1 cm in RDK apps, say for example, you want to use the app_raw_data.c then you can set the max_range_m to 1 cm inside RadarDeviceBase.cpp. See the image below for more details. 

 

Siddharth_1-1672735150573.png

Hope this helps, Thankyou

Siddharth

0 Likes

Thank you!  I tried to set the configuration as 5 cm or even 1 cm in the RadarDeviceBase.cpp. But it showed as below. I wonder if you can make sure that the device can work in this short distance? By the way, I set as Low-power short-range measurement as the official pdf(AN600     BGT60TR13C shield) shows and it also shows errors when I run the code. Sorry to trouble you.

shibiana_0-1673791865712.png

 

0 Likes
Siddharth
Moderator
Moderator
Moderator
10 solutions authored 10 likes given 25 replies posted

Hey @shibiana 

The error states that the frequency settings are out of the range, please check your Start and end frequency to be in the range of 58- 63.5 GHz. If it still doesn't work try with a fresh code by only changing the max range (chances are you might have changed some other configurations).

Thankyou, Siddharth

0 Likes
Siddharth
Moderator
Moderator
Moderator
10 solutions authored 10 likes given 25 replies posted

Hope your query was resolved. We will be locking this thread due to inactivity, please feel free to create a new query on similar or other issues. Thankyou

0 Likes