Announcements

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
kingamanu6
Level 1
Level 1
First question asked Welcome!

Hello everyone,

I want to activate 3 receiver antennas to collect the data.

  config = Avian.DeviceConfig(
        sample_rate_Hz=2e6,  # ADC sample rate of 2MHz
        rx_mask=7,  # RX antenna 3 activated
        tx_mask=1,  # TX antenna 1 activated
        tx_power_level=31,  # TX power level of 31
        if_gain_dB=33,  # 33dB if gain
        start_frequency_Hz=58e9,  # start frequency: 58.0 GHz
        end_frequency_Hz=63.5e9,  # end frequency: 63.5 GHz
        num_samples_per_chirp=256,  # 256 samples per chirp
        num_chirps_per_frame=1,  # 1 chirps per frame
        chirp_repetition_time_s=0.000150,  # Chirp repetition time (or pulse repetition time) of 150us
        frame_repetition_time_s=1 / args.frate,  # Frame repetition time default 0.005s (frame rate of 200Hz)
        mimo_mode="tdm")  # MIMO disabled
 
Here is my config.  But when I run the code, the terminal displays: device does not support the requested mode of TX antennas. How should I solve this problem?
 
Thanks.
0 Likes
1 Solution
Pugitha_N
Moderator
Moderator
Moderator
100 solutions authored 250 sign-ins 50 solutions authored

Hello @kingamanu6,

MIMO mode is not supported by BGT60TR13C.

In case of MIMO mode 2 physical TX antennas are required but BGT60TR13C has only 1 TX antenna.

Turn off the MIMO mode by changing mimo_mode =  "off" to make your config work.

Best Regards,

Pugitha

View solution in original post

0 Likes
1 Reply
Pugitha_N
Moderator
Moderator
Moderator
100 solutions authored 250 sign-ins 50 solutions authored

Hello @kingamanu6,

MIMO mode is not supported by BGT60TR13C.

In case of MIMO mode 2 physical TX antennas are required but BGT60TR13C has only 1 TX antenna.

Turn off the MIMO mode by changing mimo_mode =  "off" to make your config work.

Best Regards,

Pugitha

0 Likes