Announcements

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
mori
Level 1
Level 1
25 sign-ins 5 replies posted 10 sign-ins

Hi everyone! Now I'm using BGT60TR13C development kit for vital sensing purpose with Infineon's "Radar GUI" software. I'd like to capture pulsation signal which has around 1Hz frequency, so 100-200Hz sampling rate is preferable. But when setting higher frame rate on Radar GUI(greater than 20Hz in  my setting), fifo buffer error has occurred and failed raw signal data capturing.  Error message says to reduce Frame size = Sample per chirp * chirp per frame * Num Antennas less than 16k,  but my setting keeps this limitation(64*4*3=768<16k). So, is there any other Infineon's software to get raw IF signal data with higher frame rate? Or does anyone know other work around to solve fifo buffer error(for example, change setting of PC side)?  Thanks in advance for your cooperation.

0 Likes
1 Solution
Honey_D
Moderator
Moderator
Moderator
5 comments on blog 50 likes received 250 replies posted

Hello @mori ,

We request you to use Radar Fusion GUI with the latest FW RadarBaseboardMCU7_v255.bin flashed.

For using frame rate up to 100-200Hz, use Radar SDK Recorder app, available under C:\Infineon\Tools\Radar Development Kit\3.2.0.202205021044\application\RDK-TOOLS-SW\RDK-TOOLS-SW\SDK\apps\c\share and set the desired configuration into the config_recorder.json file as below to record the raw data

"device_config": {
"fmcw_scene": {
"rx_antennas": [1,2],
"tx_antennas": [1],
"tx_power_level": 31,
"if_gain_dB": 33,
"range_resolution_m": 0.3,
"max_range_m": 9.59,
"max_speed_m_s": 2.45,
"speed_resolution_m_s": 0.03,
"frame_repetition_time_s": 0.01 //100Hz, or 0.005 for 200Hz
}
}

After changing the json, you can compile the whole SDK, using the CMakeLists.txt given in the .\RDK-TOOLS-SW\SDK.
After compiling, you'll get a folder named "bin" in the same path, which will contain all the applications.

For recording the data run the executable with option -r , as follows:
.\app_recorder.exe -r "PATH_TO_FILENAME"

For checking out other options you can use, .\app_recorder.exe --help

Hope this helps

Best Regards,

Honey

View solution in original post

6 Replies
Honey_D
Moderator
Moderator
Moderator
5 comments on blog 50 likes received 250 replies posted

Hello @mori ,

We have tried to replicate your settings in RADAR GUI , can you verify at your end too and also share the snapshot of your screen settings to understand the error you are facing.

Radar_GUI_Snapshot.PNG

You may also check another application RADAR FUSION GUI with BGT60TR13C for capturing raw IF Signal data.

Best Regards,

Honey

0 Likes
mori
Level 1
Level 1
25 sign-ins 5 replies posted 10 sign-ins

Hello Honey-san, thank you for your reply! I have also tried above your settings. It doesn't display  range configuration, but I guessed it was  same as default setting of sample per chirp is 64 and Up chirp time is 69us.  Then, Radar GUI didn't show error message and succeeded 20Hz frame rate sampling .  But this setting is different from my settings, it's like as follows.

RadarGUI_snapshot_1.png

RadarGUI_snapshot_2.png

My application needs higher range resolution and phase measurement at higher frame rate(100-200Hz), but velocity measurement isn't necessary. So sets minimum range resolution of 3cm(maximum band width) and minimum chirp per frame of 4. Then application frame rate slide bar shows up to 200Hz setting possibility, but fails at only 20Hz setting.  I also download RADAR FUSION GUI, but "Scan devices" button didn't respond and couldn't find BGT60TR13C device, so now didn't get any progress from this approach. 

0 Likes
lock attach
Attachments are accessible only for community members.
Honey_D
Moderator
Moderator
Moderator
5 comments on blog 50 likes received 250 replies posted

Hello @mori ,

We have replicated the settings you suggested as shown in figures (RADAR_Snapshots_(1,2,3)).

Please make sure you are using the latest version of RADAR GUI 2.8.2. and the application setting is on NONE which is equivalent to extracting raw data.

For RADAR FUSION GUI :

Step 1: Make sure you have installed the latest version(3.2.0)
Step 2: Flash the firmware into the MCU_Baseboard from Device>>flash firmware option as shown in the attached figure (RADAR_FUSION_GUI)

After completing the steps you will be able to run RADAR FUSION GUI.

Please do confirm the versions of software and the firmware align with each other to make sure smooth functioning of the GUI and BGT60TR13C.

Best Regards,

Honey

0 Likes
mori
Level 1
Level 1
25 sign-ins 5 replies posted 10 sign-ins

Hello Honey-san, I thank you for your advice.  Yes, my Radar GUI version was  v2.8.1, so I updated it to latest v2.8.2. But situation doesn't change.  Setting of range resolution 0.03m, max range 0.96m, max speed 1.2m/s, speed resolution 0.6m/s frame rates 20Hz results in FIFO buffer error. I also tried Radar Fusion GUI according to your  instruction. After updating(v3.2.0) and flashing firmware, I could activate Radar Fusion GUI. This SW's setting operation seems something different from Radar GUI's one.  Because Radar GUI can change frame rate up to 200Hz when reducing chirps per frame to 4, but Radar Fusion GUI 's least chirps per frame number is 8 and maximum frame rate is 50Hz. In such settings(range resolution 0.031m, max range 1.6m, max speed 9.135m/s, speed resolution 2.284m/s frame rates 50Hz, 1TX3RX recording) , I could capture raw data without fifo buffer error. Frame rate becomes larger, but more value about 100-200Hz is preferable.  Honey-san,  do you know the way to capture raw data in 100-200Hz frame rate and 1TX3RX recording settings?

0 Likes
Honey_D
Moderator
Moderator
Moderator
5 comments on blog 50 likes received 250 replies posted

Hello @mori ,

We request you to use Radar Fusion GUI with the latest FW RadarBaseboardMCU7_v255.bin flashed.

For using frame rate up to 100-200Hz, use Radar SDK Recorder app, available under C:\Infineon\Tools\Radar Development Kit\3.2.0.202205021044\application\RDK-TOOLS-SW\RDK-TOOLS-SW\SDK\apps\c\share and set the desired configuration into the config_recorder.json file as below to record the raw data

"device_config": {
"fmcw_scene": {
"rx_antennas": [1,2],
"tx_antennas": [1],
"tx_power_level": 31,
"if_gain_dB": 33,
"range_resolution_m": 0.3,
"max_range_m": 9.59,
"max_speed_m_s": 2.45,
"speed_resolution_m_s": 0.03,
"frame_repetition_time_s": 0.01 //100Hz, or 0.005 for 200Hz
}
}

After changing the json, you can compile the whole SDK, using the CMakeLists.txt given in the .\RDK-TOOLS-SW\SDK.
After compiling, you'll get a folder named "bin" in the same path, which will contain all the applications.

For recording the data run the executable with option -r , as follows:
.\app_recorder.exe -r "PATH_TO_FILENAME"

For checking out other options you can use, .\app_recorder.exe --help

Hope this helps

Best Regards,

Honey

mori
Level 1
Level 1
25 sign-ins 5 replies posted 10 sign-ins

Helllo, Honey-san,  I appreciate your continuous assistance.
>We request you to use Radar Fusion GUI with the latest FW RadarBaseboardMCU7_v255.bin flashed.
Yes, I've flashed RadarBaseboardMCU7_v255.bin when introduced Radar Fusion GUI and doesn't change FW from that(instead Radar GUI became not to connect the device). I tried RDK-TOOLS-SW following your instruction. I found config_recorder.json file and changed it as follows for 200Hz frame rate:
{
    "device_config": {
        "fmcw_scene": {
            "rx_antennas": [1,2,3],
            "tx_antennas": [1],
            "tx_power_level": 31,
            "if_gain_dB": 33,
            "range_resolution_m": 0.031,
            "max_range_m": 1.6,
            "max_speed_m_s": 9.135,
            "speed_resolution_m_s": 2.284,
            "frame_repetition_time_s": 0.005
        }
    }
}


This settings aim at fine range resolution/short PRT/less number of chirps to achieve large frame rate for vital sensing measurement. Radar Fusion GUI shows Sample per chirp=128, Chirps per Frame=8,  Up chirp Time=133us, PRT=135.61us for this settings, so one frame needs at least 135.61usx8=1.08488ms = 1/921.76Hz. And 200Hz frame rate would be possible although other unknown restriction due to HW/communication performance might exist. I built RDK-TOOL-SW using mingw, and successfully got app_recorder.exe. I tried to run app_recorder.exe by next command:


.\app_recorder.exe -r "PATH_TO_FILENAME"


but then recorded data became samples per chirp = 64, chirps per frame=128, frame rate=10 Hz and was different from my intention. So I used -c option to specify radar configuration:


.\app_recorder.exe -r "PATH_TO_FILENAME" -c "PATH_TO_config_recorder.json"


config_recorder.json was same file as mentioned above. Then failed recording, and got next message:

 

c:\Infineon\Tools\Radar Development Kit\3.2.1.202205180921\application\RDK-TOOLS-SW\SDK\build\bin>app_recorder.exe -r test2 -c ..\..\apps\c\share\config_recorder.json
Radar SDK Version: v3.2.1+255.d520082d9
[2022-06-14 11:16:45] INFO: Opening unused board ...
File: | DeviceControlWrappers.cpp
Function: | ifx_avian_set_config
Line: | 94
Reason: | requested chirp-to-chirp time cannot be applied (IFX_ERROR_CHIRP_RATE_OUT_OF_RANGE)
Errorcode:| 0x11009
num_chirps_per_frame 8
num_samples_per_chirp 128
Failed to initialize Device. (11009)
Closing Device

 In response to this, I changed config_recorder.json settings as follows to expand chirp duration:
{
    "device_config": {
        "fmcw_scene": {
        "rx_antennas": [1,2,3],
        "tx_antennas": [1],
        "tx_power_level": 31,
        "if_gain_dB": 33,
        "range_resolution_m": 0.031,
        "max_range_m": 1.6,
        "max_speed_m_s": 4.864,
        "speed_resolution_m_s": 1.216,
        "frame_repetition_time_s": 0.005
        }
    }
}

Using this setting, I could finally get recording data with 200Hz frame rate!  My notices are:


- configuration file has to be specified with app_recorder execution command
- some FMCW timing settings seem to be restricted implicitly and needs to be set appropriate values even when they're physically possible.


Anyway, I could get a solution. Following is a snapshot of 1 minute respiration signal with 200Hz sampling rate constructing from recording data by app_recorder.exe. Here, phase processing is not complete, but around 14BPM signal is observed.  Again, thank you very much for your help, Honey-san!

mori_0-1655181380213.png