about TLE9263bqx product family serial number

Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
a119417
Level 2
Level 2
10 replies posted 5 questions asked 25 sign-ins

Hi,

I know TLE9263bqx is MID RANGE + SBC,

but when I initialize the SBC and the initail function sbc_read_reg 'SBC_FAM_PROD_STAT'',

I got something wrong here,

I got the return shows my SBC is 'DCDC_SBC_FAMILY',

anyone has idea about this?? 

0 Likes
1 Solution
Xiangrui
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 50 likes received

Hi,

If you didn't use our GUI for test, then you should take care of the SPI communication.

Xiangrui_0-1691473322423.png

TLE9263 is 16bit SPI with LSB, so it should be careful for coding and decoding.

Could you please upload your SPI waveform and part of program for further check?

Regards,

Xiangrui

View solution in original post

0 Likes
6 Replies
Xiangrui
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 50 likes received

Hi,

Is the PROD field correct with 1100?

Regards,

Xiangrui

0 Likes

Hi,

I get 33(0010 0001) in 'SBC_FAM_PROD_STAT' register, 

after bits position change, I get

family number  2(0010) and product number 1(0001)

correspond to 'DCDC_SBC_FAMILY' and 'NOTHING' 

Regards,

Ming

 

 

0 Likes
Xiangrui
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 50 likes received

Hi,

Here is the test result of TLE9263-3BQX with 0x7e (SBC Mid range+ TLE9263-3BQX)

Xiangrui_0-1691465193986.png

33 for family register makes no sense.

I wonder how did you test it. Could you please send more details like code and waveform of your test progress?

Regards,

Xiangrui

 

0 Likes

Hi,

I use TLE926x library for my test (C language),

and I found init function will return errorcode.flippedBitsMask = 0x02,

so I found there's something wrong when the init function check SBC family and product.

(init function read 'SBC_FAM_PROD_STAT' and compare to  family and product number return this wrong value 0x02)

Then I try to read the register 'SBC_FAM_PROD_STAT' which stored imformation about this, 

and got the return 33. I have 2 TLE9263bqx both of them with this wrong, did I test in the wrong way??

Regards,

Ming. 

0 Likes
Xiangrui
Moderator
Moderator
Moderator
500 replies posted 250 solutions authored 50 likes received

Hi,

If you didn't use our GUI for test, then you should take care of the SPI communication.

Xiangrui_0-1691473322423.png

TLE9263 is 16bit SPI with LSB, so it should be careful for coding and decoding.

Could you please upload your SPI waveform and part of program for further check?

Regards,

Xiangrui

0 Likes

Hi,

You are right! It may be LSB and MSB problem, after convert I get right value now.

Thanks.

Regards,

Ming.

0 Likes