Announcements

The EV market is bigger and better than ever. Join the EV Webinar to find out how you could best utiilize Power Management ICs for EVs.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Power Management ICs Forum Discussions

Luc
Level 1
Level 1
10 sign-ins 5 replies posted 5 sign-ins

I just installed the XDPP1100 GUI (Build 8334) and connecte the XDPP1100-Q024 socket debug board via USB007A dongle (FW v65). The GUI responds extremely slow if I check the "Enable Telemetry Update" in the Options menu. It will become normal when "Enable Telemetry Update" unchecked. How to solve this problem?

0 Likes
1 Solution
MarkYu1
Employee
Employee
First solution authored 5 replies posted First reply posted

Hi Luc,

Please see the picture below.

1. Make sure the I2C wires are correctly connected. 

2. Check if the I2C address is set correctly. 

markyu_0-1669614421518.png

 

View solution in original post

0 Likes
9 Replies
MarkYu1
Employee
Employee
First solution authored 5 replies posted First reply posted

Hi Luc,

Please see the picture below.

1. Make sure the I2C wires are correctly connected. 

2. Check if the I2C address is set correctly. 

markyu_0-1669614421518.png

 

0 Likes
Luc
Level 1
Level 1
10 sign-ins 5 replies posted 5 sign-ins

The I2C wires were correctly connected and the communication between the GUI and the debug  board was okay. I can write config. commands to the controller and read status from it. The only problem is when I check the "Enable Telemetry Update" in the "Options" menu, the GUI becomes extremly slow! In my experiments, I did not mannually set the I2C address at all. BTW, how to set the I2C address? Thanks for your kind help!

0 Likes
Luc
Level 1
Level 1
10 sign-ins 5 replies posted 5 sign-ins

To add a little more detail information, in GUI debugging, the patch were loaded into RAM rather than the OTP.

0 Likes
MarkYu1
Employee
Employee
First solution authored 5 replies posted First reply posted

Hi Luc,

We recently released the latest XDPP1100 GUI (Build 8334) you are using.  Could you please try to install the older version and help try again? thanks. 

0 Likes
Luc
Level 1
Level 1
10 sign-ins 5 replies posted 5 sign-ins

I tried the Build v8313. It didn't work either. Beside, I installed Build 8334 to another notebook computer and found the same issue. Could you give more advice? Thanks.

0 Likes
MarkYu1
Employee
Employee
First solution authored 5 replies posted First reply posted

Hi Luc,

Could you check if the PMBus address is correct?

please follow below steps to check the i2c/PMbus address. 

1. Go to I2C.

2. Click the button "Scan i2c/PMBus address"

The GUI will detect the i2c/PMBus address automatically. then try to read the PMBus command.

markyu_0-1670909885252.png

markyu_1-1670909922282.png

if the addresses are correct, please try to install this XDPP1100InstallationPackage.zip first, then try again. thanks. 

 

0 Likes
Luc
Level 1
Level 1
10 sign-ins 5 replies posted 5 sign-ins

The addresses are correct. But, the GUI still responds extremely slow when the "Enable Telemetry Update" is checked.

Luc_0-1670932004550.png

 

0 Likes
MarkYu1
Employee
Employee
First solution authored 5 replies posted First reply posted

Hi Luc,

Please help to uninstall and delete the version v8313 and 8334, then install the older version XDPP1100InstallationPackage.zip and try again. 

if the communication is still slow, please help to capture the I2C waveform on the I2C bus for analysis. thanks. 

 

0 Likes
MarkYu1
Employee
Employee
First solution authored 5 replies posted First reply posted

Hi Luc,

May I know if you have fixed the issue?  if no, please help try to uninstall SiLabs Driver and install it again from the path   C:\XDPP1100\SiLabsDriver\install.cmd

By default we get driver from windows and might be old. This might help.  

 

0 Likes