Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
dparikh
Level 1
Level 1
First solution authored 5 replies posted 5 sign-ins

Hi all,

I am trying to initlizing the TLF35584. I am using controller TC334 and QSPI0. all these are intilized with Infineon MCAL.

I am sending command on TXD line and seeing back to RXD line. but when I read back the register it is not showing the value which I wrote. 

Could anyone please help? if faced this issue earlier?

SPI Baud -> 6.25 Mhz

 

0 Likes
1 Solution
dparikh
Level 1
Level 1
First solution authored 5 replies posted 5 sign-ins

Hi Dw,

Thank you so much.

Issue is resolved now, I had to make few changes in SPI configs and transmission sequance. To my surprise, TLF shift out edge was wrong even though I could able to see data reflected in Rxd line. 

View solution in original post

0 Likes
5 Replies
Di_W
Moderator
Moderator
Moderator
1000 replies posted 250 solutions authored 100 likes received

Hi dparikh,

Have your SPI write and read operations worked normally? Do you mean your SPI is working but only registers of TLF35584 is not written?

dw

0 Likes
dparikh
Level 1
Level 1
First solution authored 5 replies posted 5 sign-ins

HI dw,

 

Yes My SPI is also working, I can read registers. but when I write into them and I read back I see registers are not updated as it suppose to be.

0 Likes
dparikh
Level 1
Level 1
First solution authored 5 replies posted 5 sign-ins

Update: Now I am able to write to TLF but it is not moving to normal mode after doing baudrate 5mhz data shift to trailing. 

Seq:

Unlock

disable WWD

disable ERR

lock

 

move to normal mode

0 Likes
Di_W
Moderator
Moderator
Moderator
1000 replies posted 250 solutions authored 100 likes received

Hi dparikh,

Please check whether the WWD and ERR was successfully disabled by reading RWDCFG0 and RSYSPCFG1 registers. Only after those functions are successfully disabled, the device can be configured to NORMAL mode.

 

You can also monitor the INT pin to see whether there is any error reported, in order to judge whether the SPI and move to normal command was received successfully.

 

dw

0 Likes
dparikh
Level 1
Level 1
First solution authored 5 replies posted 5 sign-ins

Hi Dw,

Thank you so much.

Issue is resolved now, I had to make few changes in SPI configs and transmission sequance. To my surprise, TLF shift out edge was wrong even though I could able to see data reflected in Rxd line. 

0 Likes