Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
Translation_Bot
Community Manager
Community Manager
Community Manager

HI Infineon,

J'ai utilisé TDA38725, mais quando il testo, ho trovato il phenomenema unstable, come ripple/turn-on waveform.

Could you help me suggest how I can adjust it? thansk.


I feel like it's compensating non-mismatch. I tried adding Ripple Injection (22k/22n/220n), but there was no significant difference. Could you adjust the compensation values based on my output? Or do you have other opinions?

 

ch1: out; ch4: phase

ripple_002.pngturnon_000.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(SCH/CODE as attachment. )

 

BR,

KAO

 

 

 

 

 

 

 

 

 

 

 

smartconx_target@Q!w2e3r4t5y6u7i8o9p0||/t5/%E9%9B%BB%E6%BA%90%E7%AE%A1%E7%90%86%E8%8A%AF%E7%89%87/TDA38725-Vout-0-8V-unstable-clarification/td-p/658140

0 Likes
1 Solution
Nishanth
Moderator
Moderator
Moderator
100 solutions authored 10 likes given 100 replies posted

Hello @KAO ,

We have an Excel design tool that will help you verify the whole design and will help to calculate the Phase and gain margin. We cannot share it in the community.

Kindly create a case under Tech support in our Infineon Case Management tool and we will be able to share the Excel design tool and provide one-to-one support.

Regards,

Nishanth

View solution in original post

0 Likes
3 Replies
Nishanth
Moderator
Moderator
Moderator
100 solutions authored 10 likes given 100 replies posted

Hello,

There are two regulators in the schematic attached.

Is the waveform similar for both regulators?

Kindly share the ripple waveform of both regulators by using a ground spring with the CRO probe.

Regards,

Nishanth

 

 

0 Likes
KAO
Level 1
Level 1
5 sign-ins First reply posted First question asked

HI Nishanth,


Yes, the issue with both power rails is the same, which leads me to believe there might be a problem with the compensation control of the controller. I use a power rail dedicated probe that is in direct contact and has the shortest path to ground. Additionally, I find that the waveforms for all my test item are not quite ideal.

Probe:https://www.tek.com/tw/datasheet/active-power-rail-probes

You can see the jitter in both no-load and full-load conditions as shown in the following figure. Additionally, the turn-off waveform drops very deeply. I conducted the tests on an empty board with only TDA38725 mounted, so my testing environment is quite clean.

0A-Jitter0A-Jitter16A-Jitter16A-Jitter16A-Turn-off16A-Turn-off

0 Likes
Nishanth
Moderator
Moderator
Moderator
100 solutions authored 10 likes given 100 replies posted

Hello @KAO ,

We have an Excel design tool that will help you verify the whole design and will help to calculate the Phase and gain margin. We cannot share it in the community.

Kindly create a case under Tech support in our Infineon Case Management tool and we will be able to share the Excel design tool and provide one-to-one support.

Regards,

Nishanth

0 Likes