Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
leonng
Level 3
Level 3
First like received First like given 10 questions asked

Hi there,

I enable NMI for alarm and ESR1

leonng_0-1657529892364.png

However, when I trigger a software alram, TLF35584 "sometime" will have an Interrupt due to "Pre-regulator voltage under voltage status flag" or "ommunication LDO under voltage status flag"  and WWD,MCU error. Why there will be a under voltage problem?

best regards,
Leon

0 Likes
2 Replies
Nambi
Moderator
Moderator
Moderator
500 replies posted 50 likes received 5 likes given

Hi,

1. You can check the value of the alarm status register on triggering a software alarm to confirm the active alarms.

2. Can you configure "No Action" for the software alarm instead of an NMI and "No FSP" configured for this and check the behavior?

3. Could you elaborate more about "TLF35584 "sometime" will have an Interrupt due to "Pre-regulator voltage under voltage status flag" or "ommunication LDO under voltage status flag"  and WWD,MCU error. " ? From, where are these flags and errors read?

Best Regards.

0 Likes
leonng
Level 3
Level 3
First like received First like given 10 questions asked

Thank you,

1. The software alarm is triggered.

2&3. 35584 will detect an error, it will make an interrupt and trigger ESR1 pin. Then, I will read 35584's register during NMI. Actually, The problem hasn't appeared in a while, and I don't know why...

I would like to know why the 35584 will detect an under voltage problem when I trigger an alarm?

best regards,
Leon

0 Likes