cancel
Showing results for 
Search instead for 
Did you mean: 

Power Management ICs

rkasi2406
New Contributor II

Hi Infineon team,

rkasi2406_0-1633504624666.png

We are using EVAL-M1-CTE610N3 for driving Washer Direct Drive Motor. We use TI C2000 MCU(28069F MCU)  for motor control.

We have made external current sensor amplification for all three phases. Below circuit diagram for one single phase given. OP-AMP used is OPA 2340.

rkasi2406_2-1633504829170.png

The RFE pin (RCIN / Fault / Enable) is not controlled from MCU and left as it is ( as per EVAL board it is pulled high to 3.3V). The temperature monitor of IPM(IM393-M6E) is also not used.

The settings were motor max current = 1.8 amps, Voltage is 310VDC.

After making all wirings we powered on the motor and it did rotate for couple of times.  After some time all the shunt resistors , ITRIP circuit, IPM are blown.

We were relying on ITRIP circuit since it is set for 6.6 amps and it is a hardware protection.

ConnectionConnection

 

Please help us in moving forward, we wanted to make our own PCB for prototyping.

 

Thanks

RaghunathanKasi

 

 

 
 

 

 

 

0 Likes
1 Solution
rkasi2406
New Contributor II

Thanks Pablo san,

Looks like shoot through is the reason since the shunt resistor and IPM are completely blown.

We did not adjust DTC at C2000 side. Our mistake we did not look into DTC requirement of 1micro sec.

we ordered the IPM and other components, we will repair the board and start our testing.

I am enclosing the logic gate schematic, to take care of shoot through at hardware side, kindly let us know is it good to include or not .

Regards

Raghu

View solution in original post

0 Likes
4 Replies
rkasi2406
New Contributor II

Hi Infineon support team,

Can you please help for the above mentioned problem.

Thanks

 

Tnaks

0 Likes
Pablo_EG
Moderator
Moderator

Hello rkasi,

Thank you for posting on Infineon Community.

I understand that you experienced a short circuit in your system.
The first reason for this could be a shoot-through event caused by insufficient deadtime.
Please check that in the motor control scheme of the C2000 there is never an overlap of PWM_L and PWM_H.
The IPM (CIPOS IM393-M6E) in the evaluation board has an internal deadtime injection.
However, Table 7 of the datasheet states that a minimum external deadtime of 1 μs is required.

https://www.infineon.com/dgdl/Infineon-IM393-M6E-DataSheet-v02_01-EN.pdf?fileId=5546d462696dbf120169...

deatime.png
In addition, the minimum pulse width acceptable is 1 μs.

Could you please confirm these two points?

Best regards,
Pablo

0 Likes
rkasi2406
New Contributor II

Thanks Pablo san,

Looks like shoot through is the reason since the shunt resistor and IPM are completely blown.

We did not adjust DTC at C2000 side. Our mistake we did not look into DTC requirement of 1micro sec.

we ordered the IPM and other components, we will repair the board and start our testing.

I am enclosing the logic gate schematic, to take care of shoot through at hardware side, kindly let us know is it good to include or not .

Regards

Raghu

View solution in original post

0 Likes
Pablo_EG
Moderator
Moderator

Hello Raghu,

Thank you very much for confirming the failure cause.

The logic schematic you attached seems OK.
However, I would like to emphasize that not only overlap is an issue but also deadtime .
As per my previous comment, please set the deadtime of the microcontroller to be greater than 1μs.

Best regards,
Pablo

0 Likes