Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ Creator & Designer Forum Discussions

Goch_4709341
Level 1
Level 1

I updated my CY8CKIT-149 to Kitprog3. PSOC Programmer recognises it and I can flash it. However when I use PSOC Creator it does not connect, saying "this device was recognized but psoc creator does not support using it at this time"

0 Likes
1 Solution
NoriakiT_91
Employee
Employee
100 likes received 50 likes received 25 likes received

I have tried with my CY8CKIT-149

KitProg3 has two modes changed by pushing the MODE (SW3) button.

1) The first one is KitProg3 CMSIS-DAP/BULK mode.  In this mode the STATUS LED (LED3) turns on stably.

The KitProg3 device is shown in the Device Manager as follows.

GS004807.png

In this mode, the device was successfully programmed.

2) The second one is KitProg3 CMSIS-DAP/HID mode. The STATUS LED (LED3) blinks in 1Hz.

GS004809.png

In this mode, the device was successfully programmed.

On my kit, both modes can be used for program.

Regards,

Noriaki

View solution in original post

2 Replies
NoriakiT_91
Employee
Employee
100 likes received 50 likes received 25 likes received

I have tried with my CY8CKIT-149

KitProg3 has two modes changed by pushing the MODE (SW3) button.

1) The first one is KitProg3 CMSIS-DAP/BULK mode.  In this mode the STATUS LED (LED3) turns on stably.

The KitProg3 device is shown in the Device Manager as follows.

GS004807.png

In this mode, the device was successfully programmed.

2) The second one is KitProg3 CMSIS-DAP/HID mode. The STATUS LED (LED3) blinks in 1Hz.

GS004809.png

In this mode, the device was successfully programmed.

On my kit, both modes can be used for program.

Regards,

Noriaki

Thanks, I tried what you suggested and today it works in both modes. Hope it still works tomorrow.

0 Likes