Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Anonymous
Not applicable

Hi, after the update to PSOC Creator 3.1 SP3 when i build a project (even a void project) the compiler raise an error:  "prj.M0120:Build Error: Existing file." (in italian "File esistente"). But what means? where is the error? There aren't other informations.

   

Thank you!

19 Replies
ETRO_SSN583
Level 9
Level 9
100 sign-ins 5 likes given 1000 replies posted

Consider posting your project, makes life easier to troubleshoot.

   

 

   

“File”                                                             Creator

   

“Create Workspace Bundle”

   

 

   

 

   

Regards, Dana.

0 Likes
Anonymous
Not applicable

here there is the zipped project

   

Ehm, i can't upload. error during the upload. 😕

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Welcome in the forum!

   

Consider to use a different browser, this mostly works. Are any of the files on a network drive? Which OS?

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Here there is the link: http://1drv.ms/1H8HNYX

   

I'm working on windows.

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Project compiled without errors or warnings on a win7 machine.

   

 

   

Bob

0 Likes
lock attach
Attachments are accessible only for community members.
Anonymous
Not applicable

this is a screenshot of the error. I've also downloaded and reinstalled PSOC creator, but the error is still there.

0 Likes
Anonymous
Not applicable

even downloaded example projects give the same error during building stage 😞

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Try to run Creator with admin rights, probably you do not have write / delete access rights to a directory.

   

Which OS are you running Creator on (WHICH windows)?

   

 

   

Bob

0 Likes
Anonymous
Not applicable

I'm running PSOC Creator on Win7 (currently updated).

   

I tried to run psoc creator in admin mode without positive results.

   

Now I'm going to run it from wine in linux...

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Probably Cypress Programmer will not run under wine, think I've seen something like that.

   

Everybody here runs Creator successfully under windows from XP to 8.1, so it must be something in your installation going wrong. I would suggest you to create a MyCase: At top of this page "Support & Community -> Technical Support -> Create a MyCase" Leave as much information as possible and your phone number.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

ok thank you! 🙂

0 Likes
Anonymous
Not applicable

ok, I've solved deleting removing the suite and the files in Appdata, then reinstalling all the programs. 🙂

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Good to hear that! Welcome in the fascinating world of PSoCs!

   

 

   

Bob

0 Likes
mame_1363116
Level 2
Level 2
Welcome!

hi ... we are making a pulse oxymeter using psoc 4200m .In the UART part we are getting an error as

   

prj.M0120 :build error .Undefined reference to 'UART_PutChar'.

   

HERE UART is the name of the sw_tx_uart we are using.

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Have a look into the generated .h -file and search for "putchar". This is usually just a typo.

   

If not, can you post your complete project, so that we all can have a look at all of your settings? To do so, use
Creator->File->Create Workspace Bundle (minimal)
and attach the resulting file.

   

When you cannot lay open your code to the public, create a support case (at top of this page -> Design Support -> Create a Support Case" and get in contact with Cypress directly. They will keep your code confidential.

   

 

   

Bob

0 Likes
mame_1363116
Level 2
Level 2
Welcome!

hi,,

   

can you please tell us how to display values on uart...

   

we are getting garbage values right now..

   

i have uploaded the project in my previous post...

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

We have November and I do not see any actual workspace you uploaded.

   

Are you using a CY8CKit-044?

   

 

   

Bob

0 Likes

yes we are using Psoc 4200M(CY8CKit-044)

0 Likes
lock attach
Attachments are accessible only for community members.
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Try this project.

   

Do not forget to set Heap Size to 0x200 in your project.

   

 

   

Bob

0 Likes