Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ Creator & Designer Forum Discussions

EyGe_3183606
Level 3
Level 3
10 sign-ins 10 replies posted 10 questions asked

Hello,

I am in need of writing some custom code of mine in both files cyfitter.h and cyfitter_cfg.c but every time I build the project, these files get regenerated and my code is erased.

Is it possible to to tell PSOC Creator not to regenerate these file? If so, how?

Thanks,
David

0 Likes
1 Solution
RyanZhao
Moderator
Moderator
Moderator
750 replies posted 100 sign-ins 100 likes received

Hi David,

I think you can try select True for Skip Code Generation in Build Settings window.

pastedImage_0.png

If Skip Code Generation become True, source files won't be re-generated, but can be built and compiled.

However, in this case, Component GUI configuration changing(such as modify ADC sample rate on ADC Component GUI in TopDesign.cysch) will be ineffective (only source code regeneration can make Component GUI re-configuration effective).

Thanks,

Ryan

View solution in original post

4 Replies
RyanZhao
Moderator
Moderator
Moderator
750 replies posted 100 sign-ins 100 likes received

Hi David,

I think you can try select True for Skip Code Generation in Build Settings window.

pastedImage_0.png

If Skip Code Generation become True, source files won't be re-generated, but can be built and compiled.

However, in this case, Component GUI configuration changing(such as modify ADC sample rate on ADC Component GUI in TopDesign.cysch) will be ineffective (only source code regeneration can make Component GUI re-configuration effective).

Thanks,

Ryan

Thank you Ryan for your resposne.

I tried your suggestion but for the file cyfitter_cfg.c the option you mentioned doesn't exist.

In addition, for the file cyfitter.h there is no possibility to select build settings since it is a header file.

0 Likes

Ah...I just forgot to say....The Build Settings is only available for project level, not for specified files...

Thanks,

Ryan

Now it works.

Thanks!

0 Likes