Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ Creator & Designer Forum Discussions

WiWi_4702256
Level 5
Level 5
10 likes received 10 likes given 5 likes given

I upgraded to 3.1.1 PDL and PSoC 4.3 the other day. Now PSoC 4.3 tells me it does not like the firmware release of the KitProg 3. I cant run at the kitProg 3 Version 1.20.x like I used too Now, having updated to kitProg3 using fw-loader and running the programmer, I used to be able to "load from device" That just hangs the programmer now... So now I have to go to Utility and reflash the kit programmer to Version 1.08 or something old like that...

Windows7Pro.jpg

CypressInstalled.jpg

0 Likes
1 Solution
Rakshith
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi WiWi_4702256​,

Now PSoC 4.3 tells me it does not like the firmware release of the KitProg 3

This is because PSoC Programmer and PSoC Creator expect a lower version of KitProg3 version. The fw-loader updates the KitProg3 to newer versions which is supported by Cypress Programmer and ModusToolbox. I do not think this issue is related to the PDL update.

When you open PSoC Programmer, it automatically shows a popup box as shown -

pastedImage_2.png

You can update the KitProg firmware to the appropriate version directly using the PSoC Programmer.

However, you can still use the device with the same KP3 firmware. I did read from device, erase all flash, load from device (without updating KP3 firmware) and this worked for me.

So now I have to go to Utility and reflash the kit programmer to Version 1.08 or something old like that...

Did this fix the issue? PSoC Programmer generally hangs when the programming settings are not correct. Can you please confirm that all the programming settings are correct?

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B

View solution in original post

0 Likes
2 Replies
Rakshith
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi WiWi_4702256​,

Now PSoC 4.3 tells me it does not like the firmware release of the KitProg 3

This is because PSoC Programmer and PSoC Creator expect a lower version of KitProg3 version. The fw-loader updates the KitProg3 to newer versions which is supported by Cypress Programmer and ModusToolbox. I do not think this issue is related to the PDL update.

When you open PSoC Programmer, it automatically shows a popup box as shown -

pastedImage_2.png

You can update the KitProg firmware to the appropriate version directly using the PSoC Programmer.

However, you can still use the device with the same KP3 firmware. I did read from device, erase all flash, load from device (without updating KP3 firmware) and this worked for me.

So now I have to go to Utility and reflash the kit programmer to Version 1.08 or something old like that...

Did this fix the issue? PSoC Programmer generally hangs when the programming settings are not correct. Can you please confirm that all the programming settings are correct?

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B
0 Likes

So, I did know I could use ver 1.20 kitProg3 with ModustoolBox. Thanks!

0 Likes