Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ Creator & Designer Forum Discussions

Anonymous
Not applicable

When I generate .hex file with PSoc Creator and I load it with PSoc Programmer I have the following error message :

   

"Debug mode enabled, this should be turned off from PSoC Creator before production"

   

How can I turn off debug mode to produce correct .hex file ?

   

My project is for PSoc 5 (CY8C5588LTI-114) and I program with JTAG.

   

Thanks in advance
 

0 Likes
1 Solution
Anonymous
Not applicable

go to  project tab and select build settings, near the top it says configuration, change it from debug to release

View solution in original post

0 Likes
4 Replies
Anonymous
Not applicable

go to  project tab and select build settings, near the top it says configuration, change it from debug to release

0 Likes
Anonymous
Not applicable

I have done it, I take file \ARM_GCC_441\Release\my_project.hex.

   

When I want to load this file with PSoc programmer I have always the same error message.

Anonymous
Not applicable

 Hello,

   

Go to CYDWR --> System TAB --> Program/Debugging --> Check "Enable Device Protection".

   

Rebuild your project and program your Hex file.

   

Please let me know if it worked for you now.

   

Thanks,

   

SRIM

Anonymous
Not applicable

It has work.

   

Thanks a lot

0 Likes