Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
Rabbit
Level 1
Level 1
First like received 5 replies posted 10 sign-ins

I fail to create project, it report error "ERROR:Makefile:171: *** Unable to find any of the available CY_TOOLS_PATHS -- C:\Infineon\Tools\ModusToolbox\tools_3.0. On Windows, use forward slashes.. Stop.".

 

Files attached.

"Enviroment Variable.png" shows the environment variable contains "C:\Infineon\Tools\ModusToolbox\tools_3.0".

 "Installation warning message.png" is the warning message during the installation.

"project-creator.txt" contain the whole log message.

 

Regards

Rabbit

0 Likes
1 Solution
Ekta_N
Moderator
Moderator
Moderator
750 replies posted First like given 250 solutions authored

Hi Sam,

If you are are unable to change the environment Variables then you can try editing the Makefile to point to the right tools directory. You would need to change CY_TOOLS_PATHS variable to point to the /ModusToolbox/tools_3.0 directory in each Makefile. You must use forward slashes in the variable’s path, even in Windows.

Ekta_0-1676534295053.png

I am not sure if the next version of Modustoolbox will fix this issue but will definitely forward this recommendation to the internal team.

Best Regards
Ekta

 

View solution in original post

0 Likes
4 Replies
Ekta_N
Moderator
Moderator
Moderator
750 replies posted First like given 250 solutions authored

Hi @Rabbit 

According to the error message it seems that you have installed modustoolbox at a non default path. Can you please confirm the same? Did you change the default path location at the time of installation?

If yes, then you will need to set the environment variable CY_TOOLS_PATHS to point to the /ModusToolbox/tools_3.0 directory, or set that variable in each Makefile.

From the image attached I could see that the installation path still points to the default location.

Best Regards
Ekta

0 Likes
Rabbit
Level 1
Level 1
First like received 5 replies posted 10 sign-ins

Hi Ekta,

You are right. I have a PC at home, it works after I change the path to /ModusToolbox/tools_3.0.

But my office PC, I can't change the PATH because of IT department disabled the "change settings" function for all company PC, our IT support can't change the PATH after spending more than half hour.

 

I can't use ModusToolBox in office, Is there other way can fix this issue? 

 

Regards

Sam

 

0 Likes
Rabbit
Level 1
Level 1
First like received 5 replies posted 10 sign-ins

Hi Ekta,

All the software installed should be automatically setup the PATH, Will the next version of ModusToolBox fix this issue?  Roughly when will be released?

Regards

Sam

0 Likes
Ekta_N
Moderator
Moderator
Moderator
750 replies posted First like given 250 solutions authored

Hi Sam,

If you are are unable to change the environment Variables then you can try editing the Makefile to point to the right tools directory. You would need to change CY_TOOLS_PATHS variable to point to the /ModusToolbox/tools_3.0 directory in each Makefile. You must use forward slashes in the variable’s path, even in Windows.

Ekta_0-1676534295053.png

I am not sure if the next version of Modustoolbox will fix this issue but will definitely forward this recommendation to the internal team.

Best Regards
Ekta

 

0 Likes