Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Level 1
Level 1


I am facing a serious problem in installing PSoC Programmer to Windows10.

Installation stops with the message "The wizard was interrupted before PSoC Programmer could be completely installed.".


It was actually hard to notice that installation was failed because the title says "InstallShield Wizard Complete".

Failed installation leaves program files in c:windows/program files(x86)/cypress and shortcuts in start menu although the PSoC Programmer can not run.

Nothing comes up on screen when clicking the PSoC Programmer from shortcut nor directly choosing the exe file.

I have tried installing v3.22.2 from CD and v3.29.0 from cypress web site but both fail in same way.

I also tried uninstalling and reinstalling but they do not show up in the installed application list.

I used Microsoft Installtion Troubleshooter. It showed them in the list but uninstalling them could not help the interruption.

I followed the information about uninstallation of Cypress Update Manager but the interruption still remianed.

I tried changing the Windows security though it does not help either.

Please help me installing it.

Best Regards,


5 Replies
Level 9
Level 9
Beta tester 500 solutions authored 1000 replies posted


Without further info from you, I'd like to venture a guess.

Do you have any virus checking programs (VCP) running?

It is a known problem installing some .exe or .dll files with some VCPs running.  Sadly some of these VCPs don't event throw up messages that they blocked an installation.

If you're running a VCP, try turning it off until the install is complete.


"Engineering is an Art. The Art of Compromise."

Hi Len,

Thanks for a kind help.

This Windows10 does not have any Virus Checking Program other than Windows default.

I have tried switching that Windows default VCP off while installing but it didn't make any difference.

Honestly, it is hard to understand which VCP function to be switched off.

If this is a rare case and not the Cypress Update Manager problem, it may be caused by Windows component which Cypress installation uses.

That component may be broken.

Although it is suspicious that Cypress Update Manager tells "Network Error" when I clicked uninstall button in its menu.

It reminds me of Cypress installer tries some network, or local data reading, during the installation and that interrupts the whole installation.

Hope there's a way to overcome.

Thanks a lot,



Here's an update for this issue. I post here for future case anyone faced same issue.

The core problem interrupting the installation was .NET Framework 3.5.
It is an additional Windows system function and it is broken unknowingly long ago, that even can not be restored by system backup.
This is a very deep system damage that even DISM command could not help.
Not yet implemented but seemingly Windows10 system repair installation would solve this, hopefully it does not bring any other disorder.

While searching this .NET Framework3.5 problem on internet, it resulted many cases.
This is a major problem Windows10 has.



Here's the final update.

Windows10 system repair installation solved all the problem.

Now .NET framework 3.5 appears clearly and I succeeded in installing PSoC Programmer.

Windows10 system repair installation took very long more than several hours but I am relieved that Windows10 started neatly almost same as before repairing.

Hope it helps someone in the future.




Thank you for the info update.

I've been monitoring the internet for Windows 10 updates/upgrades.   There were some serious security issues that Microsoft was trying to address in their latest build 2004.  On my wife's computer an update to this build it stopped her mail program from receiving new emails.

I think in Microsoft's over-precaution, they made security too tight.  Things that were working started breaking.  The later update you installed loosened it a bit.


"Engineering is an Art. The Art of Compromise."