Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ Creator & Designer Forum Discussions

GuNo_288966
Level 4
Level 4
25 replies posted 10 replies posted 10 questions asked

Hi, I have an old project from 2016 that I have built using PSoC Creator 3.3.

CY8C5868AXI-LP032.

I have frequently rebuilt it and programmed it without problems.

Now, after I additionally installed PSoC Creator 4.2, I get the error M0094 when I open the old project with PSoC Creator 3.3.

it says that a design wide resource file has been modified outside the project or so.

After build, the project does not run correctly. I am not sure what is wrong. The most obvious thing is that a display

that is connected to several GPIO pins does not show anything.

When I use the PSoC Programmer to program the old hex file, it runs as expected.

What can I do to be able to use the old project without errors and to be able to modify the old file?

0 Likes
1 Solution
GeonaP_26
Moderator
Moderator
Moderator
250 solutions authored 100 solutions authored 50 solutions authored

If you double click the project / workspace, it will open in the last installed PSoC Creator version by default. It seems that your project is opened in PSoC Creator 4.2 atleast once. If you have project backup, please continue to use Creator 3.3. Else, please use Creator 4.2 instead of Creator 3.3.

View solution in original post

0 Likes
3 Replies
KaGr_1303411
Level 2
Level 2
First like received

When you open the project in PSoC Creator, do you have to update any components to build?

If so, have you read the Component Changes section to see if there are any component changes that might affect the functionality of your project?

0 Likes
GeonaP_26
Moderator
Moderator
Moderator
250 solutions authored 100 solutions authored 50 solutions authored

If you double click the project / workspace, it will open in the last installed PSoC Creator version by default. It seems that your project is opened in PSoC Creator 4.2 atleast once. If you have project backup, please continue to use Creator 3.3. Else, please use Creator 4.2 instead of Creator 3.3.

0 Likes

Thanks, you were right.

After I restored the project from a backup that has never been touched by PSoC Creator 4.2, it worked again.

0 Likes