Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ Creator & Designer Forum Discussions

kemic_264446
Level 4
Level 4
First like received

 I can't believe PSoC creator 3.0 refuses to allow projects using PSoC 5.

   

I understand PSoC 5 has been deleted from the product catalog, and replaced with 5LP - but I still need to develop and maintain hundreds (possibly thousands) of users who have my boards with PSoC 5 on them. I make available regular software updates and almost all my users upgrade each time.

   

I understand not allowing new designs with PSoC 5, but surely we should be allowed to maintain existing projects with PSoC 5 - there can't be that much huge technical reason why the compiler can't support 5 any more.

0 Likes
12 Replies
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked
        Kenny, you will have to use Creator 2.2 for your old PSoC5 designs and may use Creator 3 for new PSoC5LP projects. Both versions are co-existent and you may install 3.0 without interferring with 2.2   
   
Bob   
0 Likes
kemic_264446
Level 4
Level 4
First like received

 Thanks Bob, I already know that.

   

My point is there will be no more updates for Creator 2.2 and I'm stuck using the old versions of the tools for what is in reality a very modern chip. Compare with Microchip - their latest IDEs still support some of their oldest chips.

   

Just because it is not recommended for new designs doesn't mean there are not a great deal of live projects out there.

   

There sure cannot be so much difference between 5 and 5LP that it means the compiler and editor simply can't handle it. I don't believe that. Yet again we get pissed on by Cypress - the reason that I have so many 5 devices out there is because I was an early adopter and got my products out there quickly.

   

I have many hundreds of active users with PSoC 5 on board which are now no longer supported by the latest development tools. It makes me very nervous about getting supplies for repairs, for one thing. It also makes me very unlikely to spec any more cypress PSoC parts in the future, because as soon as I do cypress will deprecate them and drop support for them from their tools. Once again I feel let down. It's not like I'm asking them to support parts which were last made 10s of years ago - these were still on sale earlier this year!!! 

0 Likes
Anonymous
Not applicable

 Yes  Psoc5 support please !!!!!

   

 

   

Im use two Psoc5-014 KIT

   

 

   

Kamil

0 Likes
Anonymous
Not applicable

 I must agree with the others.  I understand the move to different chips and not supporting new designs, but not supporting these chips on the new tools means that those of us with these chips in the field are forced to stay on the older tools that are frankly WAY behind the times (seriously, no Find Definition?).  This is a slap in the face to anyone that chose PSoC5 and it will cause hesitation in using PSoC again when making part choices.

0 Likes
Anonymous
Not applicable

No, it is annoying. But that's life.

0 Likes
Anonymous
Not applicable

 Hi Kenny,

   

Welcome in the fascinating world of PSoCs! :_(

   

Jan

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Kenny reported that Cypress exchanged all his PSoC5 chips with 5LPs for free.

   

My development kits and processor boards were replaced by Cypress.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

 @spiderkenny: this is nothing new. Altera and Xilinx both kill off old products with their software. The latest Quartus update, for example, eliminates Cyclone III support, and the version previous or one before that killed off Cyclone II support. There are far more of these old devices in production than PSoC5, so I can definitely see Cypress point on this. I already feel that Creator is far more bloated than it needs to be, and dropping support for older parts does help.

   

 

   

Believe me, I know how much it sucks to have to have two toolsets installed. Cypress is trying to balance the needs of all its customers. Hopefully they come out with an Eclipse-based system (as much as I hate Eclipse) so that I might finally natively run Creator on OSX and Linux.

0 Likes
Anonymous
Not applicable

 I was thrilled (not) to discover that the new dev tools dont work with the psoc 5. The psoc5lp promises to be better but imagine my delight in going to the promised upgrade/swap psoc5 to 5lp link and then discovering that it is now closed. why do they promise things in the web site only to take away.

   

Now i can either blow more money on a new dev kit or use the old tools that wont work with examples on the web. After a hiatus on psoc dev i come back to these shananigans and wonder why i am even here!

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Keep calm! Since two years not a single PSoC5 development kit was sold and for more than one year every kit was exchanged freely with a new PSoC5LP kit (without having to send back the original). So what do you want? Lifelong support? I am quite sure that some guys try to sell their replaced kit to not-knowing people.

   

Yes, I admit that the costs for a new LP-Kit is something not everyone spends freely but when you are a starter to PSoCs there might be a cheaper solution for you: Have a look at the performance of a PSoC4 and when that fulfills your requirements, get a Pioneer kit and a handfull of Prototype Kits. Always worth the money.

   

 

   

Bob

0 Likes
ETRO_SSN583
Level 9
Level 9
100 sign-ins 5 likes given 1000 replies posted

Try the following -

   

 

   

1) Contact local Regional Sales Manager to replace board.

   

2) Contact local FAE.

   

3) Put a call into Cypress and discuss your issue

   

4) File a CASE....

   

 

   

    

   

          

   

To create a technical or issue case at Cypress -

   

 

   

www.cypress.com

   

“Support”

   

“Technical Support”

   

“Create a Case”

   

 

   

You have to be registered on Cypress web site first.

   

 

   

Regards, Dana.

0 Likes
Anonymous
Not applicable

 Dumm dums. a fresh load on a faster computer with the new 5lp files loaded and and old project from a bundle. this re bundles with this screen.

   

 

   

So folks get ready for updates and more updates and more updates updates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updatesupdates and more updates and more updates, after i submit a case.

   

Try buying a new computer and running your new versions some time.

   

 

   

no kind regards here.

0 Likes