Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ Creator & Designer Forum Discussions

ETRO_SSN583
Level 9
100 sign-ins 5 likes given 1000 replies posted
Level 9

Using PSOC 6, error is asking to update PDL library to latest version.

 

It is and has been updated and reinstalled. Still error.

 

 

Regards, Dana.

 

 

0 Likes
1 Solution
Len_CONSULTRON
Level 9
1000 replies posted 750 replies posted 500 likes received
Level 9

Dana,

Leo is correct.

You can use his method to make sure the PDL library version is up to date or ...

Go to "Project/Build Settings .../<projname>/Peripheral Driver Library"

Len_CONSULTRON_0-1665147281462.png

Find the 3.1.5 version of the PDL root location using the "..." button then select "OK".

Len
"Engineering is an Art. The Art of Compromise."

View solution in original post

0 Likes
8 Replies
LeoMathews
Moderator
Moderator 50 sign-ins 10 likes received 50 replies posted
Moderator

Hi @ETRO_SSN583 

Can you please share the error log shown in the console as a text file shown in PSoC Creator?

Thanks and Regards 
Leo

0 Likes
ETRO_SSN583
Level 9
100 sign-ins 5 likes given 1000 replies posted
Level 9

ETRO_SSN583_0-1664537446982.png

Regards, Dana.

 

0 Likes
Len_CONSULTRON
Level 9
1000 replies posted 750 replies posted 500 likes received
Level 9

Dana,

I was able to build your project with no errors or warnings using Creator 4.4.

Here is the Component versions from my build:

Len_CONSULTRON_0-1664625554840.png

Do you get the same versions?

Len
"Engineering is an Art. The Art of Compromise."
0 Likes
ETRO_SSN583
Level 9
100 sign-ins 5 likes given 1000 replies posted
Level 9

I have the same components and versions.

 

Regards, Dana.

0 Likes
Len_CONSULTRON
Level 9
1000 replies posted 750 replies posted 500 likes received
Level 9

Dana,

Interesting.  As I indicated, with those versions, I have no build complaints.  Your system does complain.

Len
"Engineering is an Art. The Art of Compromise."
0 Likes
Len_CONSULTRON
Level 9
1000 replies posted 750 replies posted 500 likes received
Level 9

Dana,

Leo is correct.

You can use his method to make sure the PDL library version is up to date or ...

Go to "Project/Build Settings .../<projname>/Peripheral Driver Library"

Len_CONSULTRON_0-1665147281462.png

Find the 3.1.5 version of the PDL root location using the "..." button then select "OK".

Len
"Engineering is an Art. The Art of Compromise."
0 Likes
Len_CONSULTRON
Level 9
1000 replies posted 750 replies posted 500 likes received
Level 9

Dana,

Is this issue considered  "Solved" based on Leo's or my suggestions?

Len
"Engineering is an Art. The Art of Compromise."
0 Likes
LeoMathews
Moderator
Moderator 50 sign-ins 10 likes received 50 replies posted
Moderator

Hi @ETRO_SSN583 

Please click on the Tools tab, navigate to Options and ensure that the path for the latest PDL library location is set as shown.

LeoMathews_0-1665141433443.png

After setting the path, click on Apply and select OK. Try building the project after this configuration.

Thanks and Regards,
Leo