Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Anonymous
Not applicable

Are there old releases of the kitprog firmware and is there an easy way to load them into a kitprog adapter?

New CY8CKIT-059 boards are shipping with version 4.19, the GUI tool will only write 4.18; but, I can only get version 4.11 working under Linux with openocd.  I may be able to use something between 4.11 and 4.18, I just know that 4.11 works and 4.18/4.19 don't.

Thanks

Mike

1 Solution
HeLi_263931
Level 8
Level 8
100 likes received 50 likes received 25 likes received

You can look into your local installation of PSoC Creator or Programmer whether there are older firmware versions available.

According to KitProg FW version on CY8CKit-059  older PSoC Programmer versions come with older firmwares and can be used for downgrading.

View solution in original post

0 Likes
1 Reply
HeLi_263931
Level 8
Level 8
100 likes received 50 likes received 25 likes received

You can look into your local installation of PSoC Creator or Programmer whether there are older firmware versions available.

According to KitProg FW version on CY8CKit-059  older PSoC Programmer versions come with older firmwares and can be used for downgrading.

0 Likes