Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ Creator & Designer Forum Discussions

BeS__284136
Level 2
Level 2
Welcome!

Hello,

I work with mixed analog/digital circuits that sometimes operate on hundreds of volts.

Furthermore, the mini programmer can introduce ground loops between my PC and my circuits in development.

For my own safety, I require the use of an isolated USB hub.

I have always had issues using the PSoC MiniProg3 with isolated USB hubs (I have two of different brands). The debugger always crashes with the message below.

pastedImage_1.png

I have to power cycle the programmer to re-establish control.

Is there any fix for this issue? I do not feel comfortable connecting my electronics under test directly to my expensive ($3000.00) workbench PC. Below are the settings.

pastedImage_2.png

Thanks,

Ben

0 Likes
3 Replies
dipa_1040321
Level 1
Level 1
First like given

Hello

BeS._284136,

I will like to know which brand Isolated USB Hubs you are using.

As going for isolated usb hub decreases the usb speed.

So please check the USB Speed of the Isolated USB Hubs.

I have heard of UHR307 Isolated USB Hub which are industrial USB Hubs, you can have a look at the data sheet of the same.

0 Likes

The hubs are:

1. Intellegre USB1072

2. Advantech UH/BB-UH201 (not so much a hub, but an isolator)

0 Likes
Ekta
Moderator
Moderator
Moderator
250 solutions authored 100 likes received 250 sign-ins

Hell Ben,

Can you try the following steps:

1) In PSoC Creator goto the debug tab.

2) Click on Disable All Breakpoints

3) Click on Delete All Breakpoints

4) Build the project and then try debugging or programming using miniprog.

Please let me know if you still face issue after following the above steps.

Best Regards

Ekta

0 Likes