Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ Creator & Designer Forum Discussions

Anonymous
Not applicable

Kaspersky antivirus detects Creator 3.3SP2 as malware and kills the process.

   

It also looks for files touched by that software and reverts them. It deletes entries in the registry.

   

I first noticed this behavior several weeks ago in 3.3CP2; I reported it both here and via a service ticket. I was told it would be fixed in SP2 but it clearly hasn't been.

   

This needs to be addressed. It's been weeks since I've been able to work on my primary PC due to this bug.

   

Maybe if there were some way to tell Creator *not* to send usage statistics in, that would be something at least; it seems to be a phone-home type of operation that Kaspersky objects to.

0 Likes
1 Solution
mattl_01
Employee
Employee
100 replies posted 50 replies posted 25 replies posted

First of all, I apologize for this pain in the neck issue.

   

I've tried contacting Kaspersky, but first-line support didn't want to help me because I am not a Kaspersky user.  I'll keep looking for the proper contact. 

To turn off usage gathering statistics, go to Help->Register->PSoC Creator. You'll get a Dialog window that looks like this

   

[[{"fid":"288981","view_mode":"default","fields":{"format":"default","field_file_image_alt_text[und][0][value]":"","field_file_image_title_text[und][0][value]":""},"type":"media","attributes":{"style":"height: 400px; width: 507px; margin: 1px 5px;","class":"media-element file-default"}}]]
 

   

Just uncheck that box.  Again, sorry for the inconvenience and thanks for reporting this.

   

--Matt

View solution in original post

0 Likes
4 Replies
himam_31
Employee
Employee
50 likes received 25 likes received 10 likes received

Hello

   

 

   

We are checking about this issue.

   

 

   

Thanks,

   

Hima

0 Likes
mattl_01
Employee
Employee
100 replies posted 50 replies posted 25 replies posted

First of all, I apologize for this pain in the neck issue.

   

I've tried contacting Kaspersky, but first-line support didn't want to help me because I am not a Kaspersky user.  I'll keep looking for the proper contact. 

To turn off usage gathering statistics, go to Help->Register->PSoC Creator. You'll get a Dialog window that looks like this

   

[[{"fid":"288981","view_mode":"default","fields":{"format":"default","field_file_image_alt_text[und][0][value]":"","field_file_image_title_text[und][0][value]":""},"type":"media","attributes":{"style":"height: 400px; width: 507px; margin: 1px 5px;","class":"media-element file-default"}}]]
 

   

Just uncheck that box.  Again, sorry for the inconvenience and thanks for reporting this.

   

--Matt

0 Likes
Anonymous
Not applicable

Interesting. That box was already unchecked on my computer, and I've still experienced the problem.

   

I've resolved it, locally, by having my local IT department whitelist Creator. As soon as they did that and pushed the new rule, the problem went away.

mattl_01
Employee
Employee
100 replies posted 50 replies posted 25 replies posted

We are working with Kaspersky to get on their whitelist so folks won't have to do this in the future.

0 Likes