Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

sbider
Level 1
First solution authored First reply posted First question asked
Level 1

Goodmorning,

I took over a PsoC6 project from an ex colleague and I simply need to run it on the board (Psoc6 WiFi-BT Pioneer Kit). I must say I have zero experience with embedded development, but I only need to run the latest version of our code. My colleague left some notes, but after I follow successfully the first steps of building the project and pressing the Debug button I get the error "Error: unable to find a matching CMSIS-DAP device". The board is, of course, connected. 

I am feel bad for asking for help for a silly issue like this one, but I also don't want to waste more time trying to fix something I have absolutely no knowledge of.

Thank you

Stefano Bider

0 Likes
1 Solution
sbider
Level 1
First solution authored First reply posted First question asked
Level 1

Dear @AlenAn14 ,

thanks for the tip. When I noticed that the device was not showing up on the USB device tree, I tried switching cables. For some reason the cable I was using only delivered power.

Thank you and sorry for wasting your time.

 

Stefano 

View solution in original post

0 Likes
7 Replies
Anjali
Level 2
50 sign-ins 10 replies posted 5 questions asked
Level 2

Hi,

You might not changed the target device. Please check the target device, whether it matches your connected device!

 

0 Likes
sbider
Level 1
First solution authored First reply posted First question asked
Level 1

Could you kindly explain how to change the target device in ModulusToolbox please?

Thank you,

 

Stefano Bider

0 Likes
Anjali
Level 2
50 sign-ins 10 replies posted 5 questions asked
Level 2

Sorry, I don't know about ModulusToolbox, because I am using PSOC Creator.

 

0 Likes
AlenAn14
Moderator
Moderator 500 replies posted 100 solutions authored 250 replies posted
Moderator

Hi @sbider ,

This error can mean that the target board is not connected to your PC or the connected target board is not detected by you system
Can you please let me know if the error your observe is as below?

AlenAn14_0-1656388778847.png

Can you also check device manager and see if the target board is detected as shown:

AlenAn14_1-1656388885542.png

 

Warm Regards
Alen

0 Likes
sbider
Level 1
First solution authored First reply posted First question asked
Level 1

Dear @AlenAn14 ,

I should have specified that I am running ModulusToolbox on macOS. On this particular machine  everything was correctly setup and until my colleague left it was possible to debug. Now this is the error
Screenshot 2022-06-28 at 09.44.45.png

The device does not show up in my system USB  Device Tree

Thank you!

Stefano

0 Likes
sbider
Level 1
First solution authored First reply posted First question asked
Level 1

Dear @AlenAn14 ,

thanks for the tip. When I noticed that the device was not showing up on the USB device tree, I tried switching cables. For some reason the cable I was using only delivered power.

Thank you and sorry for wasting your time.

 

Stefano 

0 Likes
AlenAn14
Moderator
Moderator 500 replies posted 100 solutions authored 250 replies posted
Moderator

Hi @sbider ,

Glad to help and no worries, please feel free to ask any query, whether big or small in the community regarding Infineon products and we are happy to help you out on the same.

Warm Regards
Alen

0 Likes