Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
YongseokJeon
Level 4
Level 4
Distributor
50 replies posted 50 questions asked 25 replies posted

According to the previous post, the bin file was successfully created.
https://community.infineon.com/t5/PSoC-6/How-to-create-bin-file-in-Modus-Toolbox/m-p/340151#M12228

But in the following example, an error occurs when compiling.

- CY8CKIT-062-WIFI-BT
- Basic_Device_Firmware_Upgrade_boolader_cm4

a.JPG

There seems to be a problem if there are spaces in the folder, but my folder does not contain spaces.
I don't know how to solve it.

Regards,
YS

0 Likes
1 Solution

HI @YongseokJeon ,

I am observing the folder name "I2C" in the build folder instead of the target name like "CY8CKIT-062-WIFI-BT"

From your project MakeFile I found that you are renaming the name of the target build folder using the macro CY_BUILD_LOCATION.

So you need to updated the following macro as shown:

DEBUG_PATH=./$(CY_BUILD_LOCATION)/$(APPNAME)/$(TARGET)/Debug

 

Hope this helps.

Warm Regards
Alen

View solution in original post

0 Likes
5 Replies
AlenAn14
Moderator
Moderator
Moderator
500 replies posted 100 solutions authored 250 replies posted

Hi @YongseokJeon ,

According to the error message you have shared, it seems that the .elf file is not generated in the following path
<path to project>/build/<TARGET name>/Debug/
Because of it the compilation of the bin file generation command is giving you and error saying that the .elf file of the project is not found.

Can you please first perform a Build of the project from ModusToolbox and then check the above mentioned Debug folder and see if the .elf file is present in the same?

Can you also share the whole error log here as a .txt file for better analysis.

Warm Regards
Alen

0 Likes
lock attach
Attachments are accessible only for community members.
YongseokJeon
Level 4
Level 4
Distributor
50 replies posted 50 questions asked 25 replies posted

Hi, Alen.
Thanks for the quick reply.
When I compile after clean the project, .elf file is created.
I attached error log and project file.

Best Regards,
YS

0 Likes

HI @YongseokJeon ,

I am observing the folder name "I2C" in the build folder instead of the target name like "CY8CKIT-062-WIFI-BT"

From your project MakeFile I found that you are renaming the name of the target build folder using the macro CY_BUILD_LOCATION.

So you need to updated the following macro as shown:

DEBUG_PATH=./$(CY_BUILD_LOCATION)/$(APPNAME)/$(TARGET)/Debug

 

Hope this helps.

Warm Regards
Alen

0 Likes
YongseokJeon
Level 4
Level 4
Distributor
50 replies posted 50 questions asked 25 replies posted

Hi Alen,

Thanks a lot.
Now it works very well.

Best Regards,
YS

0 Likes

Hi @YongseokJeon ,

Glad your query is resolved!

Please feel free to post any queries or issues you may have on Infineon products in the community and we will be happy to help.

Warm Regards
Alen

0 Likes