Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

CoreyW_81
Employee
Employee
50 replies posted 25 replies posted 25 sign-ins

Why do these warnings come up?

Are they expected?

How does one get rid of them?

warnings.jpg

0 Likes
1 Solution

Hi,

I think that these warning comes up when you (or the system) define section in the scatter file

but the project actually did not generate/use that section.

I found description about this warning in the page 16 of AN225588

Using ModusToolbox Software with a Third-party IDE.

https://www.cypress.com/file/473316/download

It suggests to use command line

--diag_suppress=L6314W,L6329W

So I added this to Command Line > Custom Flags of both CM0+ and CM4

M0-Suppress.JPG

M4-Supress.JPG

Then I cleaned and built the project, the end part of output was

(FYI, I'm using MDK Keil V5.27)

end_of_log.JPG

moto

View solution in original post

0 Likes
9 Replies
Rakshith
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi CoreyW_81​,

Please delete the Generated_Sources folder in your project and try building your project again and see if that fixes your issue. Also try updating the components.

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B
0 Likes

Did not do anything deleting that folder.

linker.jpg

The problem is with the linker, so the advice given does not help.

0 Likes
Rakshith
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi CoreyW_81,

Please let me know the following things -

1. PSoC Creator version

2. PDL Version

3. The tool-chain and compiler used

Also, please share the project so that I can reproduce the issue.

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B
0 Likes

1. Creator 4.2

2. PDL 3.1.0

3. This:

IDE-Version:
µVision V5.28.0.0
Copyright (C) 2019 ARM Ltd and ARM Germany GmbH. All rights reserved.

Tool Version Numbers:
Toolchain:        MDK-ARM Professional  Version: 5.28.0.0
Toolchain Path:    C:\Keil_v5\ARM\ARMCC\Bin
C Compiler:         Armcc.exe V5.06 update 6 (build 750)
Assembler:          Armasm.exe V5.06 update 6 (build 750)
Linker/Locator:     ArmLink.exe        V5.06 update 6 (build 750)
Library Manager:    ArmAr.exe        V5.06 update 6 (build 750)
Hex Converter:      FromElf.exe        V5.06 update 6 (build 750)
CPU DLL:               SARMCM3.DLL V5.28.0.0
Dialog DLL:         TARMCM1.DLL V1.14.1.0
Target DLL:             CMSIS_AGDI.dll V1.31.18.0
Dialog DLL:         TARMCM1.DLL V1.14.1.0

0 Likes
Rakshith
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi CoreyW_81,

I faced this issue when my project was first compiled using GCC and then exported to Keil uVision.

The following steps fixed the issue -

1. In PSoC Creator change the Toolchain to ARM MDK Generic as shown. pastedImage_0.png

2. Clean and Build the project. All the mentioned warnings appear. If the project is exported in this step the warnings will still be present.

3. Build (not Clean and Build) the project again in PSoC Creator. You should no longer get the warnings now.

4. Export the project.

Please let me know if this fixes your issue.

Thanks and Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B
0 Likes

Seems like they tried again and still had the issues:

warnings.jpg

They will try once again.

0 Likes
JoYa_4324706
Level 3
Level 3
10 replies posted 10 questions asked 5 replies posted

Hi RakshithM_16​,

I have followed the exact steps you proposed but the same problem remains even when coverting it to Keil. The warnings came from the linker, not the compiler. Please find the simple project that I created for reference.

pastedImage_0.png

Thank you!

Best,

Joseph

0 Likes

Hi,

I think that these warning comes up when you (or the system) define section in the scatter file

but the project actually did not generate/use that section.

I found description about this warning in the page 16 of AN225588

Using ModusToolbox Software with a Third-party IDE.

https://www.cypress.com/file/473316/download

It suggests to use command line

--diag_suppress=L6314W,L6329W

So I added this to Command Line > Custom Flags of both CM0+ and CM4

M0-Suppress.JPG

M4-Supress.JPG

Then I cleaned and built the project, the end part of output was

(FYI, I'm using MDK Keil V5.27)

end_of_log.JPG

moto

0 Likes
Rakshith
Moderator
Moderator
Moderator
1000 replies posted 750 replies posted 500 replies posted

Hi CoreyW_81​,

Adding to what MoTa_728816​ mentioned, the information regarding these warnings can also be found in PSoC Creator Help Topics > Integrating into 3rd Party IDEs > PSoC 6 Designs > Creating uVision Projects for PSoC 6 in 6th point of Next Steps section.

I added the command '--diag_suppress=L6314W,L6329W' to Misc controls in Linker tab of Options for Target window and built your project and I am not getting any warnings as shown.

Options for Target Window -

pastedImage_2.png

Build Output -

pastedImage_5.png

Thank you MoTa_728816​ for providing the command to ignore these warnings.

Regards,

Rakshith M B

Thanks and Regards,
Rakshith M B