Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 6 Forum Discussions

ravo
Level 5
Level 5
5 solutions authored 100 replies posted 250 sign-ins

Dears,

I have issues with starting Debug sessions using KitProg3 or MiniProg4 even when I restart IDE (Modus Toolbox)

ravo_0-1649158013743.png

I just read all manuals, KB. and all suggested things did not help me.

Only restarting IDE, but often it doesn't help... What I have found is only I have to try cyclic ... open "Debug configuration",  then try to start debug, if it does not help then Restart whole IDE ... (sometimes it works but sometimes not working...)

Does anybody have similar issues ?

Regards

Radim

0 Likes
1 Solution
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @ravo,

Can you please click on the debug button from the quick panel as per shown in the image? Select option either JLink or KitProg3_MiniProg4 depending on your debugger.

Raj_JC_0-1650525384257.png

 

The quick panel will appear after you select the project. Please, let me know if you are getting the same error.

Thank you

Best Regards

Raj Chaudhari 

View solution in original post

0 Likes
7 Replies
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @ravo

Thank you for contacting Cypress, an Infineon Technologies Company, Technical Support! 

I believe you are able to debug the project at first after restarting the IDE. Please, let me know if you are facing the issue after that also?

As per your attached screenshot, I can see that it says "Debug session 'file_name' already started. Terminate the first one before restarting".  It means that you are already in debug mode and you have to terminate the running session. To terminate the sessions you can follow these steps:

  1. Click on the Terminate from Toolbar as shown in the figure.

Raj_JC_1-1649174038738.png

 

        ii. If it still doesn't allow to enter debug then check if the terminate but is available on the Console panel.

Raj_JC_0-1649174004232.png

After terminating the session enter the debug mode.

Please, let us know if this resolves the issue.

Thank you

Best Regards

Raj Chaudhari

0 Likes
ravo
Level 5
Level 5
5 solutions authored 100 replies posted 250 sign-ins
Dear Raj,
 
thanks for answer and tips. I understand that I must close previous debug session. But what to do when no debug was active ... and IDE Still wrote this annoying dialog.  The debug mode sometimes works, but sometimes not. But today it seems to work without problem now. I don't know whats happened. I am still testing. I will update here if IDE will bother me again. 
 
Regards
Radim
0 Likes
ravo
Level 5
Level 5
5 solutions authored 100 replies posted 250 sign-ins

Hello,

Here is small update... I am able to reproduce the strange behavior . When you start ModusToolbox (IDE) you must select and activate desired Project (in Project Explorer window) and even if it is already opened and source files already opened in editor window. When you do it, no problem occurred.

ravo_3-1649745740364.png

But If you don't select project in Explorer window after starting IDE then the error window popup. But it is a bit confuse with the text message:

ravo_0-1649745507306.png

Then I select project in Project Explorer window and try to start debug then second error message popup:

ravo_5-1649746143069.png

It is a bit confused now, because I did not have running Debug process already.

When I have looked at Proj.Explorer window after IDE starts then it look that USB_Audio is really opened. But reality is opposite... and related project settings is not loaded (e.g. cy_prj_path variable)

Conclusion: When I start IDE then I always have to select project in Project Explorer window prior to start debug process.

Radim

0 Likes
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @ravo,

Can you please click on the debug button from the quick panel as per shown in the image? Select option either JLink or KitProg3_MiniProg4 depending on your debugger.

Raj_JC_0-1650525384257.png

 

The quick panel will appear after you select the project. Please, let me know if you are getting the same error.

Thank you

Best Regards

Raj Chaudhari 

0 Likes
ravo
Level 5
Level 5
5 solutions authored 100 replies posted 250 sign-ins

Dear Raj,

When I start Modus Toolbox I have seen that both entries sections Tools and Launches are empty. Nothing displayed or grayed out here as shown in picture:

ravo_0-1650606110005.png

I know that I need to run "Refresh Quick Panel" command. But when I click on Refresh Quick Panel. It does not helped me. As I wrote earlier the workaround for me is still same: "When I start IDE then I always have to select project in Project Explorer window prior to start debug process."

If I click on project name than Launches and Tools are filled with correct entries. Then I can use buttons in quick Panel or entries from Launches... So then all works ok.

Can You confirm that I always need to manually select last used project Modus Toolbox prior to start debug/run task ? I think that this could be corrected and improved. Because in Editor view are last files opened. And then it is a bit of confusing.

Radim

0 Likes
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @ravo,

Can You confirm that I always need to manually select last used project Modus Toolbox prior to start debug/run task ? I think that this could be corrected and improved. Because in Editor view are last files opened. And then it is a bit of confusing.


 Yes, you have to select the project manually for the first time to avail the options in the Quick Panel. 

Raj_JC_0-1650619681433.png

The above error is caused by the above issue only. When you don't select the project MTB will not be able to find the project path and it throws the error.

I hope, you got the solution to all your issues.

Please, let us know if you need further support.

 

Thank you

Best Regards

Raj Chaudhari

0 Likes
ravo
Level 5
Level 5
5 solutions authored 100 replies posted 250 sign-ins

Dear Raj,

regarding this behaviour all is clear now. We can close it. But I would like note that it is not comfortable to select name of "opened project" for every time when IDE starts and even when IDE loads last opened project and show related source codes in editor. I think that this could be improved in future to be more user friendly.

Radim

0 Likes