Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Lily_cheng
Level 2
Level 2
5 replies posted 10 sign-ins First like received

 

Dears,

I have issues with starting program Dual-CPU demo. I tried restart the IDE, it keep saying the debug session already started.  I work well with one core debug, are there some notes while debug Dual-CPU demo?

 

Lily_cheng_0-1697179303836.png

 

0 Likes
1 Solution

Hello @Lily_cheng ,

My first suggestion is, please kindly create project only using MTB Project Creator instead of Eclipse "File > New". We can access project creator in this Quick Panel button:

nandax_0-1697514238734.png

Then, for the cm0p or cm4 execution (create launches, build, program, debug), please try double click the main.c of the core. Therefore, menu (buttons) in the Quick Panel will be shown like this:

nandax_1-1697514754200.png

Finally, the Debug can be done directly in the MTB Eclipse IDE (not go to Modus Shell). Please find some details in sequence on below screen shot:

nandax_2-1697515901052.png

Please kindly inform your status again after your next trials. 🙂 

Thank you and regards,
Muhammad Nanda

View solution in original post

0 Likes
5 Replies
MuhammadNanda_K
Moderator
Moderator
Moderator
250 sign-ins 250 replies posted 50 likes received

Hello @Lily_cheng ,

I just tried our Modustoolbox (MTB) sample "Dual CPU Empty PSoC 6" and can enter debug mode.
Steps that can be followed are:

  1. Open Eclipse IDE for ModusToolbox 3.1
  2. Create new project using template "Dual-CPU Empty PSoC6 App" on PSoC 6 BSP
    (I was using CY8CKIT-062S2-43012)
  3. Build xxx.proj_cm0p (xxx is project name)
  4. Choose "Generate Launches for xxx.proj_cm0p"
  5. Build xxx.proj_cm4
  6. Choose "Generate Launches for xxx.proj_cm4"
  7. Choose which core you wanted to do debugging, then choose "xxx.proj_cm... Debug (KitProg3_MiniProg4)"

If you still have issue, you can also attach minimal version of your project folder that can reproduce this problem.

I look forward to hear back from you. 🙂 

Thanks and regards,
Muhammad Nanda

0 Likes

Hello Muhammad,

thanks

 

for you apply!

I create new application using template "Dual-CPU Empty PSoC6 App" on PSoC 6 BSP.
I can't find "Generate Launches for xxx.proj_cm0p" in the quick panel.
Here is my screenshot:

Screenshot 2023-10-17 110058.jpg

 

I continue try to create a new Makefile project in a directory containing existing code, build then debug. It still has problem. 

Lily_cheng_0-1697512208075.png

2.jpg

3.jpg

Do I choose a wrong way to create? Or do I choose a wrong way to debug? Does DEBUG only be implemented  in ModusShell?Could you share you IDE screenshot?

 

0 Likes

Hello @Lily_cheng ,

My first suggestion is, please kindly create project only using MTB Project Creator instead of Eclipse "File > New". We can access project creator in this Quick Panel button:

nandax_0-1697514238734.png

Then, for the cm0p or cm4 execution (create launches, build, program, debug), please try double click the main.c of the core. Therefore, menu (buttons) in the Quick Panel will be shown like this:

nandax_1-1697514754200.png

Finally, the Debug can be done directly in the MTB Eclipse IDE (not go to Modus Shell). Please find some details in sequence on below screen shot:

nandax_2-1697515901052.png

Please kindly inform your status again after your next trials. 🙂 

Thank you and regards,
Muhammad Nanda

0 Likes
Lily_cheng
Level 2
Level 2
5 replies posted 10 sign-ins First like received

Hi Muhamad,
Thanks for your detailed solution. It's very helpful. Problem solved!

Thank you and regards,
Lily Cheng

Hello Lily Cheng,

Glad to hear that your issue has solved. 🙂
I will close this discussion then.

If you have any other issue in the future, please kindly do not hesitate to create new thread. 🙂

Thank you and regards,
Muhammad Nanda

0 Likes